Bug 1190641 - Apply/Cancel button stay grey when changing cpu threads in processor settings
Summary: Apply/Cancel button stay grey when changing cpu threads in processor settings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-09 10:33 UTC by Siteshwar Vashisht
Modified: 2019-07-11 08:37 UTC (History)
9 users (show)

Fixed In Version: virt-manager-0.9.0-29.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, when using the virt-manager GUI to change the number of CPU threads on the guest, the "Apply" and "Cancel" buttons incorrectly remained disabled. With this update, the signal and callback names in virt-manager have been corrected to properly parse changes to the cpu-thread, and the problem no longer occurs.
Clone Of:
Environment:
Last Closed: 2015-07-22 07:06:53 UTC


Attachments (Terms of Use)
Use correct signal and callback names to catch cpu-threads property changes (1.31 KB, patch)
2015-02-09 10:35 UTC, Siteshwar Vashisht
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1373 normal SHIPPED_LIVE virt-manager bug fix update 2015-07-20 17:58:44 UTC

Description Siteshwar Vashisht 2015-02-09 10:33:04 UTC
Description of problem:
Apply/Cancel button stay grey when changing number of cpu threads in processor settings

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-28

How reproducible:
Always

Steps to Reproduce:
1. Click on 'Show virtual hardware details' in vm window
2. Go to processor tab, select topology and manually set cpu topology.
3. Change number of threads.

Actual results:
Apply/Cancel button remain disabled.

Expected results:
Apply/Cancel button should be enabled.

Comment 1 Siteshwar Vashisht 2015-02-09 10:35:50 UTC
Created attachment 989635 [details]
Use correct signal and callback names to catch cpu-threads  property changes

Comment 2 tingting zheng 2015-02-10 09:01:24 UTC
Tested with:
virt-manager-0.9.0-28.el6.x86_64

Steps:
1. Prepare a guest,Click on 'Show virtual hardware details' in vm window
2. Go to processor tab, select topology and manually set cpu topology.
3. Change number of threads.

Apply/Cancel button is enabled and I can set the above configurations successfully,is there anything else I've missed?

Comment 3 Siteshwar Vashisht 2015-02-10 09:13:17 UTC
Sorry for not making the steps clear :

Steps to Reproduce:
1. Click on 'Show virtual hardware details' in vm window
2. Go to processor tab, select topology and manually set cpu topology.
3. Click on Apply button, this should disable Apply and Cancel buttons.
3. Change number of threads.

Actual results:
Apply/Cancel button remain disabled.

Expected results:
Apply/Cancel button should be enabled.

Comment 4 tingting zheng 2015-02-10 09:29:12 UTC
(In reply to Siteshwar Vashisht from comment #3)
> Sorry for not making the steps clear :
> 
> Steps to Reproduce:
> 1. Click on 'Show virtual hardware details' in vm window
> 2. Go to processor tab, select topology and manually set cpu topology.
> 3. Click on Apply button, this should disable Apply and Cancel buttons.
> 3. Change number of threads.
> 
> Actual results:
> Apply/Cancel button remain disabled.
> 
> Expected results:
> Apply/Cancel button should be enabled.

Following your steps I can reproduce it,the bug can also be reproduced on rhel6 not on rhel7.

Comment 8 Xiaodai Wang 2015-02-28 09:05:18 UTC
I can reproduce this bug with virt-manager-0.9.0-28.

# rpm -qa virt-manager
virt-manager-0.9.0-28.el6.x86_64

steps:
1. Launch virt-manager: #virt-manager
2. Open a guest and click on 'Show virtual hardware details' in vm window
3. Go to processor tab, select topology and manually set cpu topology.
4. Click on Apply button and the Apply and Cancel buttons are disabled.
5. Change number of threads, the Apply and Cancel buttons are still disabled.

Verified this issue with new build: virt-manager-0.9.0-29.el6.x86_64.rpm

Steps:
1. Update virt-manager to the latest version.
#rpm -U virt-manager-0.9.0-29.el6.x86_64.rpm
2. Check the version of virt-manager
#rpm -qa virt-manager
virt-manager-0.9.0-29.el6.x86_64
3. Launch virt-manager: #virt-manager
4. Open a guest and click on 'Show virtual hardware details' in vm window
5. Go to processor tab, select topology and manually set cpu topology.
6. Click on Apply button and the Apply and Cancel buttons are disabled.
7. Change number of threads, the Apply and Cancel buttons are enabled.

This issue is fixed in virt-manager-0.9.0-29.el6.x86_64,I will move the bug to VERIFIED.

Comment 10 errata-xmlrpc 2015-07-22 07:06:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1373.html


Note You need to log in before you can comment on or make changes to this bug.