Bug 119067 - Keyboard in unavailable for installation- emachines Laptop W/USB keyboard
Keyboard in unavailable for installation- emachines Laptop W/USB keyboard
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-24 11:53 EST by Jim Brandvold
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-24 12:36:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Brandvold 2004-03-24 11:53:23 EST
Description of problem:
The keyboard goes dead during the install.  The laptop uses USB for
both the touchpad and the built-in keyboard.  It looks like the USB
drivers aren't loaded in the kernel used for the installation

Version-Release number of selected component (if applicable):
1

How reproducible:
Boot off of the CD (iso image) on the emachines M6807 laptop

Steps to Reproduce:
1. Boot up off of CD
2. Try to run the install
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2004-03-24 12:36:18 EST
See: http://www.linuxtx.org/x86_64faq.html  - you need an external
keyboard for the install.

Probably won't be fixed for FC1 - please try FC2 development.
Comment 2 Guy Rouillier 2004-05-11 23:52:11 EDT
I just tried to install Core 2 Test 3 on 6805.  Will not recognize
built-in keyboard or mouse during install - must have external
keyboard and mouse to install.  Once installed, I tried booting
without any attachments.  Boot hangs starting up the second USB device
(ehci).  If I reboot and attach a keyboard and mouse, the system will
eventually boot up (has other problems.)  Still getting many messages
like this when booting:

atkbd.c: Unknown key released (translated set 0, code 0x41 on
isa0060/serio0).
atkbd.c: Use 'setkeycodes 41 <keycode>' to make it known.

Note You need to log in before you can comment on or make changes to this bug.