Bug 1190720 - [abrt] colord: gs_local_free(): colord-session fails to execute /usr/bin/colprof killed by SIGABRT
Summary: [abrt] colord: gs_local_free(): colord-session fails to execute /usr/bin/colp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: colord
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0a6ee287ed31a38f359a0079bf8...
: 1170022 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-09 14:21 UTC by Russell Harrison
Modified: 2015-03-25 21:12 UTC (History)
6 users (show)

Fixed In Version: colord-1.2.9-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-14 09:19:06 UTC


Attachments (Terms of Use)
File: backtrace (13.46 KB, text/plain)
2015-02-09 14:21 UTC, Russell Harrison
no flags Details
File: cgroup (190 bytes, text/plain)
2015-02-09 14:21 UTC, Russell Harrison
no flags Details
File: core_backtrace (7.17 KB, text/plain)
2015-02-09 14:21 UTC, Russell Harrison
no flags Details
File: dso_list (2.97 KB, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
File: environ (3.61 KB, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
File: limits (1.29 KB, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
File: maps (15.55 KB, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
File: open_fds (816 bytes, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
File: proc_pid_status (942 bytes, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
File: var_log_messages (161 bytes, text/plain)
2015-02-09 14:22 UTC, Russell Harrison
no flags Details
Output from colord-session -v (37.37 KB, text/plain)
2015-02-09 14:28 UTC, Russell Harrison
no flags Details

Description Russell Harrison 2015-02-09 14:21:52 UTC
Description of problem:
When creating a color profile in gnome-color-manager with a Color Munki Photo (also happens with a huey and I can test with a ColorHug if needed) colord-session will fail after saving the ti3 from dispread when attempting to execute colprof.  It appears that the executable path is either missing or corrupted in the build.

08:38:23	saving /tmp/colord-session-BVQNTX/Lenovo ThinkPad T540p (low) 2015-02-08 13-29-25 color-munki-photo.ti3
08:38:23	running ' -v -MThinkPad T540p -DThinkPad T540p -CThis profile is free of known copyright restrictions. -ql -aG Lenovo ThinkPad T540p (low) 2015-02-08 13-29-25 color-munki-photo'

When this happens the calibration window simply stops updating, displaying the last patch measured, and gives no feedback that anything has gone wrong other than nothing has changed in a very long time. I've been reproducing the issue by executing 'colord-session -v' by hand and and redirecting the output to a file so I can watch for the error by ssh'ing into the test machine and tailing the output file. The SEGABRT is coming when I click the cancel button in the calibration window.

I can get a successful profile (I think) by cd'ing into the tmp directory and executing /usr/bin/colprof with the options from the final log message.

Version-Release number of selected component:
colord-1.2.8-1.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/libexec/colord-session -v
crash_function: gs_local_free
executable:     /usr/libexec/colord-session
kernel:         3.18.5-201.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (5 frames)
 #7 gs_local_free at ../../lib/colord/cd-cleanup.h:69
 #8 cd_main_generate_profile at cd-main.c:1111
 #9 cd_main_display_characterize at cd-main.c:1247
 #10 cd_main_start_calibration at cd-main.c:1374
 #11 cd_main_start_calibration_cb at cd-main.c:1402

Comment 1 Russell Harrison 2015-02-09 14:21:55 UTC
Created attachment 989712 [details]
File: backtrace

Comment 2 Russell Harrison 2015-02-09 14:21:57 UTC
Created attachment 989713 [details]
File: cgroup

Comment 3 Russell Harrison 2015-02-09 14:21:58 UTC
Created attachment 989714 [details]
File: core_backtrace

Comment 4 Russell Harrison 2015-02-09 14:22:00 UTC
Created attachment 989715 [details]
File: dso_list

Comment 5 Russell Harrison 2015-02-09 14:22:01 UTC
Created attachment 989716 [details]
File: environ

Comment 6 Russell Harrison 2015-02-09 14:22:02 UTC
Created attachment 989717 [details]
File: limits

Comment 7 Russell Harrison 2015-02-09 14:22:04 UTC
Created attachment 989718 [details]
File: maps

Comment 8 Russell Harrison 2015-02-09 14:22:06 UTC
Created attachment 989719 [details]
File: open_fds

Comment 9 Russell Harrison 2015-02-09 14:22:07 UTC
Created attachment 989720 [details]
File: proc_pid_status

Comment 10 Russell Harrison 2015-02-09 14:22:08 UTC
Created attachment 989721 [details]
File: var_log_messages

Comment 11 Russell Harrison 2015-02-09 14:26:54 UTC
Current version of relevant packages.

$ rpm -qa 'gnome-color*' 'colord*' shared-color-targets 'icc*' 'colorhug*' 'argyl*' | sort
argyllcms-1.6.3-4.fc21.x86_64
colord-1.2.8-1.fc21.x86_64
colord-extra-profiles-1.2.8-1.fc21.noarch
colord-gtk-0.1.26-1.fc21.x86_64
colordiff-1.0.13-5.fc21.noarch
colord-kde-0.3.0-4.fc21.x86_64
colord-libs-1.2.8-1.fc21.x86_64
colorhug-client-0.2.6-0.174.20150101git.fc21.x86_64
colorhug-client-ccmx-0.2.6-0.174.20150101git.fc21.x86_64
colorhug-client-common-0.2.6-0.174.20150101git.fc21.x86_64
colorhug-client-flash-0.2.6-0.174.20150101git.fc21.x86_64
colorhug-client-refresh-0.2.6-0.174.20150101git.fc21.x86_64
gnome-color-manager-3.14.2-1.fc21.x86_64
icc-profiles-basiccolor-printing2009-1.2.0-5.fc21.noarch
icc-profiles-openicc-1.3.1-7.fc21.noarch
shared-color-targets-0.1.5-1.fc21.noarch

Comment 12 Russell Harrison 2015-02-09 14:28:49 UTC
Created attachment 989723 [details]
Output from colord-session -v

Output of colord-session -v &> lenovo_t540p-gcm-2015-02-08-08-28-colord-session.out

Comment 13 Tim Waugh 2015-02-23 10:00:00 UTC
I've just submitted a pull request upstream for a change which fixes it for me.
https://github.com/hughsie/colord/pull/12

Comment 14 Tim Waugh 2015-02-23 10:01:05 UTC
*** Bug 1170022 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2015-03-09 14:19:35 UTC
colord-1.2.9-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/colord-1.2.9-2.fc21

Comment 16 Fedora Update System 2015-03-10 00:53:53 UTC
Package colord-1.2.9-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing colord-1.2.9-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3540/colord-1.2.9-2.fc21
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2015-03-14 09:19:06 UTC
colord-1.2.9-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Jean-François Fortin Tam 2015-03-25 21:12:56 UTC
FWIW this fixes the most important problems, the colormunki design/photo can now calibrate in quick/normal mode, though it still fails in slow (accurate) mode; see also https://bugs.freedesktop.org/show_bug.cgi?id=87519


Note You need to log in before you can comment on or make changes to this bug.