This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 119076 - avc denied /usr/sbin/gpm
avc denied /usr/sbin/gpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Ben Levenson
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-24 13:24 EST by Ben Levenson
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.7.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-24 17:14:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2004-03-24 13:24:17 EST
Description of problem:
'service gpm restart' produces the following avc denial:

avc:  denied  { read } for  pid=3597 exe=/usr/sbin/gpm name=localtime
dev=dm-0 ino=924810 scontext=root:system_r:gpm_t
tcontext=root:object_r:etc_t tclass=file

Version-Release number of selected component (if applicable):
policy-1.9-15

from audit2allow:
allow gpm_t etc_t:file { read };
Comment 1 Bill Nottingham 2004-03-24 13:43:15 EST
Actually, /etc/localtime should probably be readable by all domains.
Comment 2 Daniel Walsh 2004-03-24 13:55:29 EST
This looks like a labeling problem.

/etc/localtime should be locale_t

Who create localtime?

How could it get mislabeled?
Comment 3 Ben Levenson 2004-03-24 15:20:36 EST
switching timezones with 'system-config-{date,time}' rewrites
/etc/localtime:
before: system_u:object_r:locale_t
after: root:object_r:etc_t

adding system-config-date owner to Cc
Comment 4 Daniel Walsh 2004-03-24 15:46:10 EST
If instead of removing the localtime, you could copy over it.  This
would maintain the security context.

Dan
Comment 5 Brent Fox 2004-03-24 16:03:37 EST
Should be fixed in system-config-date-1.7.3-1 in dist-fc2-hold.
Comment 6 Ben Levenson 2004-03-24 17:14:27 EST
file context is preserved with s-c-d-1.7.3-1.

Note You need to log in before you can comment on or make changes to this bug.