Bug 1190860 - chronyd.service fails shortly after being started on arm
Summary: chronyd.service fails shortly after being started on arm
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: chrony
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2015-02-09 19:45 UTC by Paul Whalen
Modified: 2015-02-10 04:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-10 04:26:15 UTC


Attachments (Terms of Use)
journalctl -u chronyd.service -o verbose (15.23 KB, text/plain)
2015-02-09 19:45 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2015-02-09 19:45:35 UTC
Created attachment 989832 [details]
journalctl -u chronyd.service -o verbose

Description of problem:
chronyd fails shortly after being started. sets the time and then silently fails. 

Version-Release number of selected component (if applicable):
chrony-2.0-0.2.pre1.fc22.armv7hl

How reproducible:


Steps to Reproduce:
1. boot system with chronyd.service enabled
2. service starts, then silently fails
3.

Actual results:

 systemctl status chronyd -l
��● chronyd.service - NTP client/server
   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2015-02-09 13:04:10 EST; 1h 31min ago
 Main PID: 495 (code=exited, status=1/FAILURE)

Feb 09 13:04:08 localhost.localdomain chronyd[495]: Source 69.28.67.44 offline
Feb 09 13:04:08 localhost.localdomain chronyd[495]: Source 192.95.20.208 offline
Feb 09 13:04:09 localhost.localdomain chronyd[495]: Source 192.95.20.208 online
Feb 09 13:04:09 localhost.localdomain chronyd[495]: Source 162.219.6.68 online
Feb 09 13:04:09 localhost.localdomain chronyd[495]: Source 167.88.45.230 online
Feb 09 13:04:09 localhost.localdomain chronyd[495]: Source 69.28.67.44 online
Feb 09 13:04:10 localhost.localdomain chronyd[495]: Selected source 69.28.67.44
Feb 09 13:04:10 localhost.localdomain systemd[1]: chronyd.service: main process exited, code=exited, status=1/FAILURE
Feb 09 13:04:10 localhost.localdomain systemd[1]: Unit chronyd.service entered failed state.
Feb 09 13:04:10 localhost.localdomain systemd[1]: chronyd.service failed.


Additional info:
audit.log

type=SERVICE_START msg=audit(1423510997.650:513): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=chronyd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
type=SERVICE_STOP msg=audit(1423511003.280:514): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=chronyd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

Comment 1 Paul Whalen 2015-02-09 21:45:49 UTC

[root@localhost ~]# chronyd -d
2015-02-09T21:38:03Z chronyd version 2.0-pre1 starting (+CMDMON +NTP +REFCLOCK +RTC +PRIVDROP +DEBUG +ASYNCDNS +IPV6 +SECHASH)
2015-02-09T21:38:09Z Selected source 69.28.83.155
2015-02-09T21:38:09Z Fatal error : adjtimex failed for set_frequency, freq_ppm=-8.3333e+04 required_freq=3.3333e+01 required_tick=10833
 
Looks like - https://bugzilla.redhat.com/show_bug.cgi?id=1188074

Comment 2 Peter Robinson 2015-02-09 21:51:40 UTC
Pretty sure this is the same as https://bugzilla.redhat.com/show_bug.cgi?id=1188074

It was reproducable in 3.19rc as well as 3.18, can you check 3.19 GA too?

Comment 3 Paul Whalen 2015-02-10 04:26:15 UTC
Resolved in kernel-3.19.0-1.fc22.


Note You need to log in before you can comment on or make changes to this bug.