Bug 1190960 - [whql][netkvm][mq]job failed due to "Received some net buffer lists out of order" w/ 4 queues
Summary: [whql][netkvm][mq]job failed due to "Received some net buffer lists out of or...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1206279 (view as bug list)
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-02-10 06:00 UTC by lijin
Modified: 2016-11-04 08:44 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:44:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
win7-32- job 2c_Mini6RSSSendRec failed with single queue (3.00 MB, application/zip)
2016-06-12 02:38 UTC, Peixiu Hou
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description lijin 2015-02-10 06:00:41 UTC
Description of problem:
job "NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv
" and "NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)
" failed with error "Received some net buffer lists out of order"

win8-32,win8.1-32:
NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv

win8-64,win8.1-64,win2012,win2012R2:
NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.2-20.el7.x86_64
kernel-3.10.0-223.el7.x86_64
seabios-1.7.5-4.el7.x86_64
virtio-win-prewhql-100

How reproducible:
100%

Steps to Reproduce:
1.boot guests with:
nic1:
/usr/libexec/qemu-kvm -name 100NICWIN864CSC -enable-kvm -m 2G -smp 8,cores=8 -uuid 8bcdebe8-6417-40bf-8390-a4af83704ec8 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/100NICWIN864CSC,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=100NICWIN864CSC,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x64_dvd_917522.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=100NICWIN864CSC.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:70:42:74:ba,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:71:2f:db:ed,bus=pci.0,mq=on,vectors=10

nic2:
/usr/libexec/qemu-kvm -name 100NICWIN864SSC -enable-kvm -m 2G -smp 4 -uuid fa9842e1-8a2b-489a-9558-7e9734a87d94 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/100NICWIN864SSC,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=100NICWIN864SSC,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_8_enterprise_x64_dvd_917522.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=100NICWIN864SSC.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:6a:7d:9f:7d,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:17:7e:8a:fc,bus=pci.0,mq=on,vectors=10

2.submit job "NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)" in hck


Actual results:
job failed

Expected results:
job can pass 

Additional info:

Comment 7 Yan Vugenfirer 2015-03-11 09:36:19 UTC
Please attach the latest logs

Comment 17 Yossi Hindin 2015-03-23 20:20:55 UTC
Hi

  Please, add the launching script you are using with 101NIC201264CGL/101NIC201264SGL, in case it is different from reported in the bug description.

   Regards,
      Joseph Hindin

Comment 21 Vadim Rozenfeld 2015-05-24 08:27:33 UTC
please check with the latest build, available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/104/win/virtio-win-prewhql-0.1.zip

Comment 23 lijin 2015-06-16 04:49:09 UTC
Jobs all pass in build105 netkvm whql test
So this issue has been fixed.

Comment 27 Yan Vugenfirer 2015-07-22 09:23:47 UTC
*** Bug 1206279 has been marked as a duplicate of this bug. ***

Comment 28 Yu Wang 2015-07-31 03:37:25 UTC
win2012R2 hit this issue with build106
Job Name:NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)

Run command:
Client:
/usr/libexec/qemu-kvm -name 106NIC2012R2CED -enable-kvm -m 6G -smp 8 -uuid e92e7b31-9f4e-4fcb-a82a-1c94df69edd6 -nodefconfig -nodefaults -cpu Nehalem,+fsgsbase -chardev socket,id=charmonitor,path=/tmp/106NIC2012R2CED,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=106NIC2012R2CED,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=106NIC2012R2CED.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:0d:18:da:f3,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=8 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:3d:66:0b:23,bus=pci.0,mq=on,vectors=18

Support:
/usr/libexec/qemu-kvm -name 106NIC2012R2SED -enable-kvm -m 6G -smp 8 -uuid 56547627-c9e9-41d5-8ab9-70756f4e5474 -nodefconfig -nodefaults -cpu Nehalem,+fsgsbase -chardev socket,id=charmonitor,path=/tmp/106NIC2012R2SED,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=106NIC2012R2SED,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_r2_x64_dvd_2707946.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=106NIC2012R2SED.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:60:78:f7:90,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=8 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:3a:55:43:28,bus=pci.0,mq=on,vectors=18

The log shows "Received some net buffer lists out of order" and failed

hck log(named 106-netkvm-2012R2-mini8rss-2c.zip) is located in http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/virtio-win/bug1190960/

Comment 31 Yan Vugenfirer 2016-01-05 09:43:53 UTC
Please retest with latest build

Comment 32 lijin 2016-01-05 10:02:17 UTC
According to the virtio-win-prewhql-111 netkvm whql test result,job "NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv" and "NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)" passed on all OSes.
So this issue has been fixed already.

Comment 34 lijin 2016-01-15 03:04:00 UTC
re-assign this issue according to comment#33

Comment 41 Peixiu Hou 2016-06-12 02:38:54 UTC
Created attachment 1167058 [details]
win7-32- job 2c_Mini6RSSSendRec failed with single queue

Comment 47 Peixiu Hou 2016-06-30 16:31:33 UTC
Hi Yan,

Verified this issue with virtio-win-prewhql-0.1-121

Steps as comment#0

Test passed With single queue & multiqueue:
"NDISTest 6.0 - [2 Machine]- 2c_Mini6RSSSendRecv" -Win7-32 
"NDISTest 6.0 - [2 Machine]- 2c_Mini6RSSSendRecv" -Win7-64 
"NDISTest 6.0 - [2 Machine]- 2c_Mini6RSSSendRecv (Multi-Group Win8+)" -Win2012R2

According to above, the issue has been fixed.

Best Regards~
Peixiu Hou

Comment 48 Yu Wang 2016-07-01 04:46:39 UTC
according to comment47, change status to verified

thanks
Yu Wang

Comment 51 errata-xmlrpc 2016-11-04 08:44:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.