Bug 1190968 - [whql][netkvm][mq]job "NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids" last for hours and never stop w/ 4 queues
Summary: [whql][netkvm][mq]job "NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids" last for...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-10 06:41 UTC by lijin
Modified: 2015-11-24 08:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:49:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
win2012 job running screen shot (76.83 KB, image/png)
2015-02-10 06:41 UTC, lijin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description lijin 2015-02-10 06:41:50 UTC
Created attachment 989986 [details]
win2012 job running screen shot

Description of problem:
job "NDISTest 6.0 - [1 Machine] - 1c_Mini6RSSOids" should be finished in about 5 minutes,but it last 20+ hours and seems never will stop.
win8-32/64,win8.1-32/64,win2012,win2012R2 all hit this issue.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.1.2-20.el7.x86_64
kernel-3.10.0-223.el7.x86_64
seabios-1.7.5-4.el7.x86_64
virtio-win-prewhql-100

How reproducible:
100%

Steps to Reproduce:
1.boot guest with:
nic1:
/usr/libexec/qemu-kvm -name 100NIC201264CV0 -enable-kvm -m 6G -smp 8,cores=8 -uuid 9f1a76d7-1c93-46ff-9a18-f8062d9f4e85 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/100NIC201264CV0,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=100NIC201264CV0,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2012_x64_dvd_915478.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=100NIC201264CV0.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:00:3d:86:d7,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:0f:6f:d1:67,bus=pci.0,mq=on,vectors=10

2.submit job in hck

Actual results:
job running for 20+ hours,never stop(please check the attachement)

Expected results:
job can pass correctly

Additional info:

Comment 8 lijin 2015-03-10 02:59:51 UTC
still hit this issue with build 101

Comment 9 Yossi Hindin 2015-03-12 12:49:27 UTC
Hi

   Recently, I've successfully run 1c_Mini6RSSOids test on Windows 8.1 32 bits with 8 CPUS. Please, give me an access to your testing environment for further investigation.

    Regards,
       Joseph Hindin

Comment 11 Yossi Hindin 2015-03-13 10:50:37 UTC
Hi

   Recently, we have found that tests involving CPU grouping with Windows 8 may fail because of Windows-related issue with qemu.  Adding hv_spinlocks=0x1FFF to -cpu may help.

   Please, try to run the test with this option and if it would still fail, give me access to the testing environment.

    Regards,
        Joseph Hindin

Comment 12 Yossi Hindin 2015-03-15 17:15:29 UTC
Hi
    I've downloaded the stack from the stalled state and am looking into a problem. After I've rebooted the client machine, the test passed several time.
Still I think it is possible that the problem was caused by a bug in the NetKVM driver, so it the test would stall again, please, let me access the testing environment again.

    Regards,
        Joseph Hindin

Comment 14 Yossi Hindin 2015-03-18 14:41:59 UTC
Hi
   I tried to access the test machine, but it looks like the virtual machine is down. Please, start the test virtual machine as described in comment # 10 and let me investigate the issue.
   It will also help me a lot if you would describe how do you launch HCK and its' client virtual machines. 

    Regards,
         Joseph Hindin

Comment 15 lijin 2015-03-19 01:22:55 UTC
boot 101NICBLUE32CYK image up again,please have a check.

steps to launch hck and virtual machine;
1.boot/install guest on host with specific device;
2.install virtio-win driver and hck client in guest,and other configuration(firewall,UAC,xxx);
3.rdesktop to the hck server and open HCK Manager,create a new machine pool(bug1190968);then drag the related machine(101NICBLUE32CYK) from 'default pool' to this new machine pool,and right click it,change the machine status into 'Ready';
4.open HCK Studio,create a new project(name usually same as the the machine pool,bug1190968),chose the correct machine pool(bug1190968) from 'Selection' tab,and select 'Red Hat Virtio Etherpad Adapter' in 'device manager';Finally click the job in 'Tests' tab to run the job.

if anything else,please let me know :)

Comment 17 lijin 2015-07-17 08:04:20 UTC
change status to verified as with build 105,all jobs passed with queues=4

Comment 19 errata-xmlrpc 2015-11-24 08:49:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.