Bug 11910 - Anacron and SysVinit
Summary: Anacron and SysVinit
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anacron (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-05 07:10 UTC by Jose Carlos Ramirez Perez
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-05 07:10:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jose Carlos Ramirez Perez 2000-06-05 07:10:33 UTC
The Anacron package does not have installation and uninstall scripts to
add itself to the SysVinit directory, so its jobs are never executed.

Also the stop script may use the SIGUSR1 signal instead of KILL because
this will wait for currently running jobs to end.

These are example install/uninstall scripts:

postinstall script (through /bin/sh):
/sbin/chkconfig --add anacron
preuninstall script (through /bin/sh):
if [ $1 = 0 ]; then
    /sbin/chkconfig --del anacron
fi

Comment 1 Bernhard Rosenkraenzer 2000-06-16 10:36:06 UTC
Acutally anacron isn't supposed to have a sysv init script at all, it's not a
daemon.
This is fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.