Bug 119100 - NFS statd fails to release locks during cleanup
NFS statd fails to release locks during cleanup
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-24 20:28 EST by Greg Marsden
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:22:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Marsden 2004-03-24 20:28:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20040130 Firebird/0.7

Description of problem:
NFS statd fails to release locks during cleanup when client hostname
differs from the client's nodename. This is because the NLM and NSM
processes are split between kernel and userspace, so the userspace
process can perform a gethostbyname while the kernel space statd cannot.

This is a result of client configuration, but should be considered an
nfs bug as well.

This can be resolved by making the NSM and NLM hostnames match, or by
causing NSM to stop using dns lookup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change hostname
2. flock a file over NFS (succeeds)
3. reboot system
4. try to flock file again (fails)
    

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:22:57 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.