Bug 119114 - mountd fails all mounts unless /proc/fs/nfs is mounted
mountd fails all mounts unless /proc/fs/nfs is mounted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 01:23 EST by Alex Kiernan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 04:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Kiernan 2004-03-25 01:23:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
All NFS exports fail as mountd returns NFSERR_ACCES from all calls, 
unles /proc/fs/nfs is a mounted instance of the filesystem nfsd

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-19.fc2

How reproducible:
Always

Steps to Reproduce:
1. Export a directory to a host
2. Mount from another
3.
    

Additional info:

Problem seems to be related to the change to check_new_cache - the 
actual failure is around line 307 in mountd.c:

   306                  cache_export(exp);
   307                  fh = cache_get_filehandle(exp, v3?64:32, p);
   308                  if (fh == NULL) 
   309                          *error = NFSERR_ACCES;
   310                  else
   311                          *error = NFS_OK;

fh always ends up being null
Comment 1 Alex Kiernan 2004-04-07 04:05:18 EDT
problem's gone away, not sure what package ended up providing the
mount, but it works now.

Note You need to log in before you can comment on or make changes to this bug.