Bug 1191248 - Repeating error messages when adding a new organization or location
Summary: Repeating error messages when adding a new organization or location
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.7
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-10 20:14 UTC by Brett Thurber
Modified: 2019-09-25 20:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:13:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
Repeating error messages (82.38 KB, image/png)
2015-02-10 20:14 UTC, Brett Thurber
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC
Foreman Issue Tracker 9447 None None None 2016-04-22 16:08:34 UTC

Description Brett Thurber 2015-02-10 20:14:34 UTC
Created attachment 990231 [details]
Repeating error messages

Description of problem:
Creating a New Organization: Leaving Name and Label blank results in error strings of "can't be blank, can't be blank, and must contain at least 1 character" and "can't be blank, can't be blank,  cannot contain characters other than ascii alpha numerals, '_', '-'. ,  and must contain at least 1 character" SS #516 Also duplicates the message when an org name is already in use "has already been taken and has already been taken" 

Version-Release number of selected component (if applicable):
6.0.7

How reproducible:
N/A

Steps to Reproduce:
1. Create a new organization and leave fields blank
2. Click Submit
3. Repeating error messages appear

Actual results:
Repeating error messages for blank fields.

Expected results:
Single error message.

Additional info:
Screen shot attached.

Comment 1 RHEL Product and Program Management 2015-02-10 20:23:22 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-02-18 21:15:38 UTC
Created redmine issue http://projects.theforeman.org/issues/9447 from this bug

Comment 4 Bryan Kearney 2015-08-25 18:33:37 UTC
Upstream bug component is Content Management

Comment 5 Bryan Kearney 2015-11-19 19:02:48 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 6 Bryan Kearney 2015-11-20 15:02:50 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9447 has been closed
-------------
Justin Sherrill
Applied in changeset commit:katello|a1cb786b4d84fa3de5f498daa46a636d4b66ecd0.

Comment 7 Tazim Kolhar 2015-12-18 08:55:08 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:

# rpm -qa | grep foreman
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
foreman-debug-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-ovirt-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
foreman-postgresql-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-vmware-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
foreman-gce-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
dell-per300-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-release-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
foreman-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-libvirt-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
dell-per300-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
dell-per300-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201512101420git81ec371.el7.noarch
foreman-compute-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
foreman-proxy-1.11.0-0.develop.201512101505git62c9e22.el7.noarch

steps:
Steps to Reproduce:
1. Create a new organization and leave fields blank
2. Click Submit

Single Error messages no repetition

Comment 11 errata-xmlrpc 2016-07-27 09:13:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.