Bug 119129 - autologin drop-down userlist includes nfsnobody
autologin drop-down userlist includes nfsnobody
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-25 06:31 EST by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 09:15:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm-nfsnobody.patch (1.26 KB, patch)
2004-05-10 07:35 EDT, Tim Waugh
no flags Details | Diff
gdm-spec.patch (1.36 KB, patch)
2004-05-10 07:36 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2004-03-25 06:31:21 EST
Description of problem:
The gdmsetup autologin drop-down userlist includes nfsnobody, but
shouldn't.

Version-Release number of selected component (if applicable):
gdm-2.5.90.2-3

How reproducible:
100%
Comment 1 Nils Philippsen 2004-04-16 12:55:10 EDT
This is still the case with gdm-2.6.0.0-2. The reason is that
nfsnobody's UID is 65534 which doesn't get filtered by MinimalUID=500
in /etc/X11/gdm/gdm.conf.

Maybe we should hardcode "&& pwent->pw_uid < 65534 " into
gui/gdmsetup.c:508 or try to introduce a new option MaximalUID upstream?
Comment 2 Colin Charles 2004-05-07 14:43:14 EDT
Still reproducable in gdm-2.6.0.0-3
Comment 3 Tim Waugh 2004-05-10 07:35:47 EDT
Created attachment 100122 [details]
gdm-nfsnobody.patch
Comment 4 Tim Waugh 2004-05-10 07:36:51 EDT
Created attachment 100123 [details]
gdm-spec.patch

This minimal fix works for me.
Comment 5 Mark McLoughlin 2004-06-04 09:15:55 EDT
Thanks for the patch Tim. We'll figure this one out upstream:

http://bugzilla.gnome.org/show_bug.cgi?id=143707

Note You need to log in before you can comment on or make changes to this bug.