This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 119144 - Icons dissapear immediately following upgrade to KDE 3.2.1 (KDE/QT apps only, so far)
Icons dissapear immediately following upgrade to KDE 3.2.1 (KDE/QT apps only,...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 10:45 EST by Steven P. Ulrick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 11:45:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steven P. Ulrick 2004-03-25 10:45:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
Immediately following a recent upgrade from KDE 3.2.0 (RPM's, from
ftp.kde.org or one of it's official mirrors) to KDE 3.2.1 (RPM's, also
from ftp.kde.org or one of it's offcial mirrors) I lost icons in, so
far, four applications - Bibletime, Krename, Kover and Krusader. The
icons that I lost are the ones that compile and install with the above
mentioned applications. The icons that the above mentioned
applications use from KDE itself are all there.
I tried recompiling and reinstalling 3 of the 4 mentioned
applications, to see if that would fix the problem - no such luck. I
also tried installing from RPM's for some of the above mentioned
applications, no luck there either.
It bears mentioning that all of the icons that are now missing Were
Not missing before I upgraded to KDE 3.2.1. I noticed the absence of
the icons almost immediately after upgrading. I'll restate that this way:
1. Under KDE 3.2.0, all icons display properly.
2. Updgrade to KDE 3.2.1, making no changes to the above mentioned
applications, and icons that come from the applications dissapear.

The RPM's that I used to updgrade came from ftp.kde.org.
In case someone further mentions that it is an issue with the
applications themselves, I must ask, why did the icons work before I
updgraded?
In closing, here is a point that makes this issue different than the
closest one that I found before submitting this: the only applications
that are afflicted with this bug are KDE applications. There is not a
non-KDE application among the ones that I have notices issues with so
far. 

Version-Release number of selected component (if applicable):
kde 3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Use "rpm -Uvh" to upgrade from KDE 3.2.0 to KDE 3.2.1
2. Restart KDE (Logout and Log back in)

Actual Results:  The absence of most icons in at least four KDE/QT
based applications.  At least the following:
1. Bibletime
2. Krename
3. Krusader
4. Kover

Expected Results:  I expected the icons that had been there up to and
including under KDE 3.2.0 to still be present.

Additional info:

I have since reverted back to KDE 3.2.0.  But I will upgrade back to
KDE 3.2.1 later today, maybe early tomorrow morning, so I can give you
even more detailed information.  I want to be of service to you :)
Also, I don't know for sure that I got the component right, but if you
need me to change it, let me know what the correct component is, and I
will gladly change it :)
Comment 1 Ngo Than 2004-03-25 14:22:33 EST
it looks like these applications are not from KDE 3.2.1 packages!
and i bet it's aa Categories issue in desktop files.

Where are the desktop files of these applications installed?
could you please send me the desktop files of them? thanks

Does it work if you add this "Categories=Qt;KDE;Utility;" in the
desktop files?
Comment 2 Steven P. Ulrick 2004-03-25 16:01:33 EST
I pasted "Categories=Qt;KDE;Utility;" (minus the quotation marks) into
the ".desktop" files that are associated with the four apps that I
used as examples of applications with missing icons.  I saved them and
then logged out and logged back in. Still no icons.

While trying the above, I noticed the contents of certain parts of the
"/usr/share/applnk" directory (An extreme lack of icons in certain
sections)  I put a screenshot at the following location:
http://www.faith4miracle.org/kde-3.2.1-ScreenShots/kde-3.2.1-DissapearingIcons-ScreenShot-1.jpg

Here is a link to the ".desktop" files you requested.  Please note,
that in the Bibletime, Krename and Krusader files, if you remove the
line that you suggested that I add to them, then the file is in the
exact condition that it was in before I edited them.  With Kover, just
delete the line you told me to paste in, and uncomment the original
Categorie line, and it is then back to it's original condition.
http://www.faith4miracle.org/kde-3.2.1-Other/kde-3.2.1-DesktopFiles.tar.bz2

I did not attatch this screen shot or ".desktop" files, because I've
had problems attatching things to bug reports before.  Also, I didn't
know what would happen if I put the above quoted URL into the URL box:
would I be able to add another screenshot in that box, if needed?

If you need anything else from me, screenshots, whatever, I'll be glad
to oblige.  Anything you want me to try, editing files, recompiling,
applying patches, just let me know :)
Comment 3 Steven P. Ulrick 2004-03-26 05:07:38 EST
As an experiment, I tried the following:
1. Updated every KDE module from the CVS.
2. configure, make, make install on arts, kdelibs, kdebase (so far)
3. Logged out of KDE, logged back in.

The result of the above three steps?  All of my icons are back!
I uploaded a screenshot of the exact same view of /usr/share/applnk to
the following location:
http://www.faith4miracle.org/kde-3.2.1-ScreenShots/kde-3.2.1-DissapearingIcons-ScreenShot-NEW.jpg

Like I may have said before, I am no guru with Linux, but I do pretty
well.  (Really well according to my brother, who IS a Linux guru.)  I
was wondering, is it significant that, using the QT that I downloaded
with KDE 3.2.1 for Fedora Core 1, after installing only Arts, Kdelibs
and Kdebase, that the bug that this report is the subject of would
appear to be fixed?  In fact, as a bonus, the excessively large icons
in the KDE start menu, which HAD caused my start menu to be two
columns wide while running KDE 3.2.1, is now back to it's normal size
:)  In closing, all of these complaints of mine are now fixed, after
updating my system from the CVS.  Perhaps they were fixed in the KDE
code itself, or possibly there was something wrong with one of the KDE
3.2.1 RPM's for Fedora Core?  If anything interesting comes up as I
continue installing from the CVS, I'll let you know.  As soon as a fix
occurs that you release as an RPM, I will gladly redownload and
reinstall KDE 3.2.1 from the RPM's
Comment 4 Ngo Than 2004-04-02 11:45:05 EST
i have done a fresh FC2 test2 installation. i cannot reproduce this
problem here. It seems it's fixed now with current KDE 3.2.1 rawhide

Note You need to log in before you can comment on or make changes to this bug.