Bug 1191530 - Undercloud parameters pxe_deploy_ramdisk and pxe_deploy_kernel are not passed to ironic
Summary: Undercloud parameters pxe_deploy_ramdisk and pxe_deploy_kernel are not passed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Angus Thomas
QA Contact: Toure Dunnon
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-11 13:13 UTC by Marek Aufart
Modified: 2015-08-05 13:50 UTC (History)
6 users (show)

Fixed In Version: openstack-tuskar-ui-0.3.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 156216 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Marek Aufart 2015-02-11 13:13:32 UTC
Description of problem: When deploying nodes on undercloud, deployment fails with cinder-storage-1-servers | CREATE_FAILED | Error: Resource CREATE failed: Error: Resource CREATE failed: Error: Server ov-krri3qtcd-0-d3lrema43va4-BlockStorage-ppileflcdaaw delete failed: (500) No valid host was found.
Log shows:
Feb  9 10:29:19 localhost ironic-api: InstanceDeployFailure: RPC do_node_deploy failed to validate deploy info. Error: Cannot validate PXE bootloader. The following parameters were not passed to ironic: ['pxe_deploy_ramdisk', 'pxe_deploy_kernel']


Version-Release number of selected component (if applicable):

How reproducible: Consistent

Steps to Reproduce: Follow https://mojo.redhat.com/docs/DOC-1010112, define nodes (using nodes.csv), assign nodes to role (at least one controller and compute, does not matter), click Deploy and wait


Actual results: Error message | CREATE_FAILED | Error: Resource CREATE failed: Error: Resource CREATE failed: Error: Server ov-krri3qtcd-0-d3lrema43va4-BlockStorage-ppileflcdaaw delete failed: (500) No valid host was found

Expected results: Message Deploy completed.

Additional info: nova flavor-show 502fdb94-ee20-4d62-b28e-4cdfc4eddfce shows: ...extra_specs                | {"cpu_arch": "x86_64", "baremetal:deploy_kernel_id": "", "baremetal:deploy_ramdisk_id": ""}

expected is: … extra_specs                | {"cpu_arch": "x86_64", "baremetal:deploy_kernel_id": "62703b5c-e814-4872-8930-c7322680327c", "baremetal:deploy_ramdisk_id": "c146efbd-e4cf-4748-acb8-9ce022a90d8e"}

Workaround is to use console and nova command, eg:
nova flavor-key 502fdb94-ee20-4d62-b28e-4cdfc4eddfce set baremetal:deploy_ramdisk_id=c146efbd-e4cf-4748-acb8-9ce022a90d8e
nova flavor-key 502fdb94-ee20-4d62-b28e-4cdfc4eddfce set baremetal:deploy_kernel_id=62703b5c-e814-4872-8930-c7322680327c

Comment 4 Radomir Dopieralski 2015-02-16 10:54:05 UTC
How was the flavor created?

Comment 5 Marek Aufart 2015-02-16 12:04:50 UTC
It was created by the link "suggested flavor".

Comment 6 Radomir Dopieralski 2015-02-16 13:24:41 UTC
Flavors created using the "suggested flavor" link don't have the images set, because there is no way to know which images are correct at that point.

I suppose we need to remove the "create" option from there, and leave only "edit before creating" option, so that the user can select the correct images.

Comment 7 Radomir Dopieralski 2015-03-03 14:11:12 UTC
Merged upstream.

Comment 15 errata-xmlrpc 2015-08-05 13:50:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.