Bug 1191579 - python3-dnf cannot be used without python2
Summary: python3-dnf cannot be used without python2
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-11 14:28 UTC by Lukas Slebodnik
Modified: 2015-04-06 18:49 UTC (History)
8 users (show)

Fixed In Version: dnf-plugins-extras-0.0.6-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:49:12 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lukas Slebodnik 2015-02-11 14:28:12 UTC
Description of problem:
python3-dnf requires dnf which requires python2. Therefore python3-dnf cannot be used without python2. As a result if this I cannot prepare minimal container image without python2.

[root@host ~]# rpm -q --requires python3-dnf | grep "python\|dnf"
/usr/bin/python3
dnf = 0.6.3-2.fc21
python(abi) = 3.4
python3-hawkey >= 0.5.2
python3-iniparse
python3-libcomps >= 0.1.6
python3-librepo >= 1.7.5
python3-pygpgme
rpm-python3 >= 4.12.0

[root@host ~]# rpm -q --requires dnf | grep "python\|dnf"
/usr/bin/python
config(dnf) = 0.6.3-2.fc21
python(abi) = 2.7
python-hawkey >= 0.5.2
python-iniparse
python-libcomps >= 0.1.6
python-librepo >= 1.7.5
rpm-python >= 4.12.0


Version-Release number of selected component (if applicable):

[root@host ~]# rpm -q python3-dnf dnf
python3-dnf-0.6.3-2.fc21.noarch
dnf-0.6.3-2.fc21.noarch

How reproducible:
Deterministic

Comment 1 Martin Kosek 2015-02-11 14:49:41 UTC
CCing Slavek, he should be aware.

Comment 2 Bohuslav "Slavek" Kabrda 2015-02-11 15:03:15 UTC
AFAIK dnf should be switched to python3-dnf in F22 and rawhide, so this shouldn't be a problem when the switch happens... But someone from dnf maintainers should confirm.

Comment 3 Lukas Slebodnik 2015-02-11 15:16:26 UTC
The most problematic part is that configuration file is owned by package "dnf"
The packaging need to be changed anyway because python3-dnf does not work without configuration file.

[root@host ~]# rpm -ql dnf | grep "/etc"
/etc/bash_completion.d/dnf-completion.bash
/etc/dnf
/etc/dnf/dnf.conf
/etc/dnf/plugins
/etc/dnf/protected.d/dnf.conf
/etc/libreport/events.d/collect_dnf.conf
/etc/logrotate.d/dnf

[root@host ~]# rpm -ql python3-dnf | grep "/etc"
[root@host ~]# echo $?
1

Comment 4 Honza Silhan 2015-03-05 17:24:33 UTC
The packaging of DNF was changed, the packages should be independent in f21, f22, f23 and epel7 for python API usage. This PR [1] moves conf inside each subpackage so it can be run from cmdline too.

[1] https://github.com/rpm-software-management/dnf/pull/236

Comment 5 Fedora Update System 2015-03-31 18:17:40 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 6 Fedora Update System 2015-04-02 01:43:56 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2015-04-03 11:39:22 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 8 Fedora Update System 2015-04-06 18:49:12 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.