Bug 1191594 - LVM RAID - Add support for 'raid0' segment type to lvm2 tools
Summary: LVM RAID - Add support for 'raid0' segment type to lvm2 tools
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.3
Assignee: Heinz Mauelshagen
QA Contact: cluster-qe@redhat.com
Milan Navratil
URL:
Whiteboard:
Depends On: 1335861
Blocks: 1189124 1346081 1390358
TreeView+ depends on / blocked
 
Reported: 2015-02-11 14:53 UTC by Heinz Mauelshagen
Modified: 2016-11-04 04:08 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
LVM2 tools now support the `raid0` segment type The `raid0` segment type is mandatory to support the Multiple Devices (MD) type reshaping from a `striped` layout using 'raid0' to 'raid5' and others, and to create native MD "raid0" striped logical volumes (LVs). Now, LVM2 supports segment types "raid0" and raid0_meta", that is native striping that the MD kernel runtime supports.
Clone Of:
: 1390358 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:08:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Heinz Mauelshagen 2015-02-11 14:53:10 UTC
Description of problem:
lvm2 is missing RAID0 support based on the MD RAID0 personality

How reproducible:
Always

Steps to Reproduce:
1. lvcreate --type raid0 -l1 -i2 -nr $VG
2.
3.

Actual results:
Error

Expected results:
Succeeds creating a reid0 mapping

Additional info:
lvm2 tools/lib need 'raid0' segment type added using a respective enhancement to the dm-raid target (see seperate kernel bz) which shall utilize the MD 'raid0' personality.
The mandatory allocation of internal metadata LVs (aka rmeta LVs) as with the already supported MD-based raid levels (RAID1/10/4/5/6) shall be optional, because the MD 'raid0' personality does _not_ require metadata devices unless a takeover from 'raid0' to 'raid5' is requested. The distinction between 'raid0' LVs with and without metadata LVs may be based on the segement type name (e.g. segment type name 'raid0' -> no internal metadata LVs vs. 'raid0_meta' -> allocate internal metadata LVs)

Comment 2 Jonathan Earl Brassow 2015-07-22 13:31:06 UTC
Didn't make 7.2 devel freeze.  Will include this with the reshaping patches for 7.3.

Comment 5 Alasdair Kergon 2016-07-06 00:28:53 UTC
Support for raid0 and raid0_meta segments included in 2.02.159.

Comment 7 Corey Marthaler 2016-07-29 20:09:43 UTC
All applicable raid test cases have been tried and passed on raid0, as well as in exclusive mode for both clvmd and lvmlockd mode.

3.10.0-480.el7.x86_64

lvm2-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-libs-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
lvm2-cluster-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-event-libs-1.02.131-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
device-mapper-persistent-data-0.6.3-1.el7    BUILT: Fri Jul 22 05:29:13 CDT 2016
cmirror-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016
sanlock-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
sanlock-lib-3.4.0-1.el7    BUILT: Fri Jun 10 11:41:03 CDT 2016
lvm2-lockd-2.02.161-3.el7    BUILT: Thu Jul 28 09:31:24 CDT 2016

Comment 8 Corey Marthaler 2016-08-15 23:15:44 UTC
bug 1367223 should really block this feature.

Comment 15 errata-xmlrpc 2016-11-04 04:08:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.