Bug 11917 - authconfig doesn't allow specification of multiple NIS servers
authconfig doesn't allow specification of multiple NIS servers
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: authconfig (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-05 18:44 EDT by Michael S. Fischer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-05 18:44:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael S. Fischer 2000-06-05 18:44:12 EDT
In its current incarnation, authconfig does not allow one to specify that
the server should explicitly bind to more than one server.  Only a single
server, or broadcast, is allowed.  This can cause problems like cron
sporadically spitting out error messages like

yp_all: clnt_call: RPC: Unable to receive; errno = Connection reset by peer

Which, according to Miquel van Smoorenburg at
<http://x59.deja.com/getdoc.xp?AN=606419756&CONTEXT=960243430.682622982&hitnum=3>,
is spit out to stderr by glibc during a NIS server switch.  In the article
referenced he mentions that explicitly setting the server names instead of
using broadcast should help reduce the problem.

However, I can't get authconfig to do it for me by having multiple
--nisserver command-line options.  I really would like this feature because
otherwise I'll have to tweak /etc/yp.conf manually during the
post-kickstart phase.
Comment 1 Nalin Dahyabhai 2000-06-10 17:05:31 EDT
This is now fixed in the version of authconfig in our build tree.  To simplify
the code that parses command-line options, you can list multiple NIS servers if
you separate them with commas (i.e., "--nisserver yp1.baz.com,yp2.baz.com").

Note You need to log in before you can comment on or make changes to this bug.