Bug 1191713 - /etc/os-release moved in fedora-release, causes installer images to fail to boot
Summary: /etc/os-release moved in fedora-release, causes installer images to fail to boot
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1191847 (view as bug list)
Depends On:
Blocks: F22AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-11 19:39 UTC by Adam Williamson
Modified: 2015-02-16 23:09 UTC (History)
8 users (show)

Fixed In Version: lorax-22.5-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 23:09:20 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1191847 0 unspecified CLOSED Failed to start switch root while using HTTP/FTP repository for installation. 2021-02-22 00:41:40 UTC

Internal Links: 1191847

Description Adam Williamson 2015-02-11 19:39:27 UTC
The Branched 2015-02-11 x86_64 nightly fails to boot with:

Failed  to switch root: Specified switch root path /sysroot does not seem to be an OS tree. os-release file is missing.

Indeed there is no /sysroot/etc/os-release . I believe this is caused by a change to fedora-release:

* Tue Feb 10 2015 Peter Robinson <pbrobinson@fedoraproject.org> 22-0.11
...
- Move os-release to /usr/lib and symlink to etc (rhbz#1149568)

lorax share/runtime-cleanup.tmpl has this:

removefrom fedora-release --allbut /etc/os-release

I'd guess that doesn't work when /etc/os-release is a symlink to /usr/lib/os-release ?

This is an automatic Alpha blocker under the automatic blocker policy:

"Complete failure of any release-blocking TC/RC image to boot at all under any circumstance - "DOA" image (conditional failure is not an automatic blocker)"

Comment 1 Vratislav Podzimek 2015-02-12 10:12:14 UTC
*** Bug 1191847 has been marked as a duplicate of this bug. ***

Comment 2 Fabian Deutsch 2015-02-16 08:45:55 UTC
This bug has been fixed for me in todays nightly build.


Note You need to log in before you can comment on or make changes to this bug.