Bug 1191875 - subnet without organization/location and host using the subnet in org/loc => unable to set org/loc on the subnet
Summary: subnet without organization/location and host using the subnet in org/loc => ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-12 07:46 UTC by Jan Hutař
Modified: 2019-09-26 14:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:47:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 9391 None None None 2016-04-22 14:54:22 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jan Hutař 2015-02-12 07:46:17 UTC
Description of problem:
When you create subnet without organization/location specified and create host using the subnet with organization/location, you are unable to configure organization/location for the subnet.


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. Install Satellite (I have not created any extra organization/location
   besides default ones)
2. Configure provisioning (in my case I have used libvirt)
3. Create subnet without organization/location specified
   # hammer -u admin -p changeme subnet create --dhcp-id 1 --dns-id 1 \
     --tftp-id 1 --domain-ids 1 --name jhutar3 --network 192.168.160.0 \
     --mask 255.255.255.0
4. Create host using that subnet
5. Make sure you have "Default Organization@Default Location"
6. Look into Infrastructure -> Subnets
   => you can not see the subnet, which is expected
7. Switch to "Any Context"
8. Look into Infrastructure -> Subnets
   => you can see the subnet, which is expected
9. Attempt to set organization/location in Infrastructure -> Subnets
   -> <your_subnet> -> Locations or Organizations
   => default org/loc are already at right side (tooltip says
      "This is used by a host") and you can not configure it in any way


Actual results:
You can not configure it in any way


Expected results:
You should probably be able to configure it, or when it seems to be configured already (see step 9), it should appear with "Default Organization@Default Location" set as well.

Comment 1 RHEL Program Management 2015-02-12 07:53:18 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Ohad Levy 2015-02-15 08:55:48 UTC
Created redmine issue http://projects.theforeman.org/issues/9391 from this bug

Comment 4 Jan Hutař 2015-02-15 21:09:58 UTC
Same for Compute Resource

Comment 5 Bryan Kearney 2015-02-18 23:06:47 UTC
Upstream bug assigned to sshtein@redhat.com

Comment 6 Bryan Kearney 2015-04-22 12:05:08 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/9391 has been closed
-------------
Shimon Shtein
Applied in changeset commit:8f695d94a2f32fea3363cc017fc59baf6ca15b17.

Comment 9 Kedar Bidarkar 2016-05-03 16:04:40 UTC
Looks like this is no longer an issue, as we can no longer create a host without subnet first being associated to a org/loc , neither via UI nor via hammer.

Can you please confirm this?

Comment 10 Kedar Bidarkar 2016-05-03 16:08:29 UTC
confirmed that we can no longer add subnet to host via UI and hammer, unless the subnet is part of the org/loc.


VERIFIED With sat62-snap9.3

Comment 12 errata-xmlrpc 2016-07-27 08:47:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.