Bug 119190 - no sound due to snd_pcm_oss not loading on startup
no sound due to snd_pcm_oss not loading on startup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 22:22 EST by James Walton
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-08 00:49:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modprobe.conf (456 bytes, text/plain)
2004-04-01 17:56 EST, James Walton
no flags Details

  None (edit)
Description James Walton 2004-03-25 22:22:41 EST
Description of problem:
xmms, mplayer, gaim, etc have no sound until I run the Soundcard
Detection app under GNOME.  When running the Detection the test sound
plays, and after that all other applications have sound even if they
were already running.  This happens after every reboot. The module
snd_pcm_oss is not being loaded, and after loading the volume is 0 for
ALSA PCM and all of the OSS mixer.
 
 
Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253.2.1
system-config-soundcard-1.2.7-3
 
How reproducible: Every time
 
 
Steps to Reproduce:
1. Bootup and Login
2. Try to play any sounds
3.
 
   
Actual results:
No sound
 
Expected results:
Sound
 
Additional info:
Running Soundcard detection fixes the problem, or manually loading
snd_pcm_oss
and adjusting volume
 
$ /sbin/lspci | grep Multimedia
00:08.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 04)
 
Before Detection
$ /sbin/lsmod |grep snd
snd_mixer_oss          13952  1
snd_ens1371            24544  2
snd_rawmidi            21408  1 snd_ens1371
snd_seq_device          6280  1 snd_rawmidi
snd_pcm                84232  1 snd_ens1371
snd_page_alloc          8580  1 snd_pcm
snd_timer              25220  1 snd_pcm
snd_ac97_codec         53384  1 snd_ens1371
gameport                3968  1 snd_ens1371
snd                    43748  9
snd_mixer_oss,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer,snd_ac97_codec
soundcore               7520  2 snd
 
After Detection
$ /sbin/lsmod |grep snd
snd_pcm_oss            42532  0
snd_mixer_oss          13952  2 snd_pcm_oss
snd_ens1371            24544  2
snd_rawmidi            21408  1 snd_ens1371
snd_seq_device          6280  1 snd_rawmidi
snd_pcm                84232  2 snd_pcm_oss,snd_ens1371
snd_page_alloc          8580  1 snd_pcm
snd_timer              25220  1 snd_pcm
snd_ac97_codec         53384  1 snd_ens1371
gameport                3968  1 snd_ens1371
snd                    43748  10
snd_pcm_oss,snd_mixer_oss,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer,snd_ac97_codec
soundcore               7520  2 snd
Comment 1 Sahil Verma 2004-03-29 19:19:54 EST
Please post /etc/modprobe.conf
Comment 2 James Walton 2004-04-01 17:56:32 EST
Created attachment 99055 [details]
modprobe.conf

Sorry for the delay, been a busy week.
Comment 3 James Walton 2004-04-06 21:03:48 EDT
Just upgraded to kernel 2.6.4-1.305 and now sound seems to be working
with the same configuration as before, and snd_pcm_oss doesn't need to
be loaded.

Note You need to log in before you can comment on or make changes to this bug.