Bug 119193 - slocate can not find anything.
slocate can not find anything.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: SELinux
Depends On:
Blocks: 122683
  Show dependency treegraph
 
Reported: 2004-03-26 01:23 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.10.1-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 14:41:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-03-26 01:23:11 EST
When I run locate from staff_r, I get a bunch of messages of the form

audit(1080282148.605:0): avc:  denied  { read } for  pid=7704
exe=/usr/bin/slocate name=xxxx dev=hda2 ino=1573113
scontext=aleksey:staff_r:staff_locate_t
tcontext=aleksey:object_r:staff_home_t tclass=lnk_file
audit(1080282148.620:0): avc:  denied  { read } for  pid=7704
exe=/usr/bin/slocate name=yyyy dev=hda2 ino=1409767
scontext=aleksey:staff_r:staff_locate_t
tcontext=aleksey:object_r:staff_home_t tclass=lnk_file

(where names all match the pattern I was trying to locate) and slocate
does not print any matches.

I am currently using policy-sources-1.9-15
Comment 1 Daniel Walsh 2004-03-26 09:42:17 EST
What are you trying to slocate?

Dan
Comment 2 Aleksey Nogin 2004-03-26 14:37:09 EST
No matter what I try to locate, if I run "locate xyz" under staff_r,
it never works (and I have to run it under sudo to get any output)...
Comment 3 Daniel Walsh 2004-04-08 09:36:54 EDT
Added allow rule to policy-1.10-1-5
Comment 4 Aleksey Nogin 2004-05-07 14:41:54 EDT
This has been working correctly for a while now.

Note You need to log in before you can comment on or make changes to this bug.