Bug 119202 - anaconda_t can't run userhelper apps
Summary: anaconda_t can't run userhelper apps
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policy
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-26 11:19 UTC by Tim Waugh
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-04-02 18:47:56 UTC


Attachments (Terms of Use)

Description Tim Waugh 2004-03-26 11:19:01 UTC
Description of problem:
During a kickstart %post script I set up some print queues the way I
like them like this:

printconf-tui --Ximport <<"EOF"
...
EOF

This works in Fedora Core 1, but with current rawhide I have to run
'/usr/sbin/printconf-tui' or else it doesn't work.

Possible solutions:

- run kickstart with /usr/sbin earlier in the PATH than /usr/bin

or

- have anaconda_t able to run userhelper without password

Version-Release number of selected component (if applicable):
policy-1.9-15
anaconda-9.91-7

How reproducible:
100%

Steps to Reproduce:
1. Try running a userhelper app in a kickstart script.

Comment 1 Daniel Walsh 2004-03-26 15:28:53 UTC
Changed anaconda to allow rootok in main files.

Fixed in policy-1_9-18


Comment 2 Tim Waugh 2004-04-02 18:47:56 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.