Bug 1192090 - Get rid of Python 2 dependencies in hplip
Summary: Get rid of Python 2 dependencies in hplip
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-12 15:36 UTC by Bohuslav "Slavek" Kabrda
Modified: 2015-02-12 18:17 UTC (History)
2 users (show)

Fixed In Version: hplip-3.15.2-2.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-12 18:17:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Bohuslav "Slavek" Kabrda 2015-02-12 15:36:11 UTC
Hi, it seems that hplip and hplip-gui depend on both Python 2 and Python 3. It seems that this is cause by some "#!/usr/bin/python" hashbangs in scripts, which generate auto RPM dependencies on Python 2. Could you please get rid of these to have Python 3-only builds of hplip?
Thanks.

Comment 1 Tim Waugh 2015-02-12 18:17:15 UTC
Thanks for spotting it.


Note You need to log in before you can comment on or make changes to this bug.