Bug 119212 - (SCSI CCISS)Process crash during "engage scsi" for HP Smart Array i5
(SCSI CCISS)Process crash during "engage scsi" for HP Smart Array i5
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-03-26 09:14 EST by Fred Zwarts
Modified: 2015-01-04 17:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 02:14:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Extract from /var/log/messages (2.27 KB, text/plain)
2004-03-29 04:29 EST, Fred Zwarts
no flags Details

  None (edit)
Description Fred Zwarts 2004-03-26 09:14:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; 
T312461; Q312461)

Description of problem:
We have a Proliant DL380 G3 server system, which has a HP Smart Array 
i5 disk controller. For backup purposes we have a SCSI tape drive 
attached to this system. In order to enable the use of the SCSI port 
the command

echo "engage scsi" >/proc/driver/cciss/cciss0

is needed. (This worked with RedHat 8.0 and Fedore core 1.)

When we try this with Fedore core 2 test 1, the bash process crashes 
and a new login prompt appears. After loging in again, the command

more /proc/driver/cciss/cciss0

does show a sequential access device, but the tape drive is still not 
accessible. Retrying the "engage scsi" command returns a message that 
the scsi subsystem is already engaged.

So, we are not able to perform backups.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Log in as root.

2. execute the command
echo "engage scsi" >/proc/driver/cciss/cciss0


Actual Results:  The (bash) process crashes.

Expected Results:  The tape drive being accessible. E.g.,
mt -f /dev/st0 status
should return a success status instead of an error status.

Additional info:
Comment 1 Arjan van de Ven 2004-03-29 04:09:42 EST
is there an oops of some sort in dmesg output? if so can you attach
that to this bug ?
Comment 2 Fred Zwarts 2004-03-29 04:28:03 EST
dmesg does not contain any information, but I found something in
messages. I'll add it to the report.
Comment 3 Fred Zwarts 2004-03-29 04:29:57 EST
Created attachment 98918 [details]
Extract from /var/log/messages

This is the extract from /var/log/messages I mentioned a few minutes ago.
Comment 4 Dave Jones 2004-12-08 00:50:13 EST
any improvement with the 2.6.9 update kernel ?
Comment 5 Dave Jones 2005-04-16 02:14:36 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.