Bug 1192131 - webUI console for libvirt host is not aligned correctly
Summary: webUI console for libvirt host is not aligned correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-12 16:32 UTC by Jan Hutař
Modified: 2019-09-26 17:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:47:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (29.10 KB, image/png)
2015-02-12 16:32 UTC, Jan Hutař
no flags Details
console aligned on webUI (143.78 KB, image/png)
2016-04-20 12:17 UTC, Sachin Ghai
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 9442 None None None 2016-04-22 16:20:01 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jan Hutař 2015-02-12 16:32:21 UTC
Created attachment 991035 [details]
screenshot

Description of problem:
webUI console for libvirt host is not aligned correctly


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. Setup Satellite in a way you can provision in libvirtd (on same system
   as Satellite in my case)
2. Create new host and go to its console via:
   Hosts -> All hosts -> <your_host> -> [Console]


Actual results:
VNC console/window alignment looks strange.


Expected results:
Console (VNC window) should be aligned below green bar.

Comment 1 RHEL Program Management 2015-02-12 16:43:25 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-02-18 21:09:13 UTC
Created redmine issue http://projects.theforeman.org/issues/9442 from this bug

Comment 4 Jan Hutař 2015-07-01 09:47:16 UTC
When you add:

  style="float: none;"

to div#noVNC_status, noVNC canvas gets aligned correctly (but the status bar got shorter, which probably needs to be fixed).

Comment 5 Jan Hutař 2015-07-01 09:48:55 UTC
In upstream ticket dcleal suggested this is caused by Patternfly which IMO comes with Katello.

Comment 7 Bryan Kearney 2015-08-25 18:33:45 UTC
Upstream bug component is Provisioning

Comment 8 Daniel Lobato Garcia 2015-12-10 09:26:31 UTC
Ohad no - this has not been fixed as part of Patternfly upstream.

Comment 9 Ohad Levy 2016-03-16 08:34:57 UTC
this is no longer reproduceable on snap1, setting it to on QE (this was most likely solved with the migration of patternfly upstream.

Comment 11 Sachin Ghai 2016-04-20 12:16:34 UTC
Verified with sat6.2 beta snap8.2

I can see webUI console aligned properly. Please seethe attached screenshot.

Comment 12 Sachin Ghai 2016-04-20 12:17:08 UTC
Created attachment 1149069 [details]
console aligned on webUI

Comment 14 errata-xmlrpc 2016-07-27 08:47:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.