Bug 1192145 - When a role is not used in a deployment you get a warning: "Role has no flavor"
Summary: When a role is not used in a deployment you get a warning: "Role has no flavor"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ga
: Director
Assignee: Ana Krivokapic
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-12 16:59 UTC by Udi
Modified: 2015-08-05 13:50 UTC (History)
5 users (show)

Fixed In Version: openstack-tuskar-ui-0.3.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 155803 None None None Never
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Udi 2015-02-12 16:59:02 UTC
Description of problem:
When you don't use all the roles in the deployment, warnings near the "Deploy" button appears: 
Role swift-storage has no flavor. ( Associate this role with a flavor. )
Role cinder-storage has no flavor. ( Associate this role with a flavor. ) 


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.7.9-10.el7ost.noarch
openstack-tripleo-0.0.5-2c3fb309727671130a32b4c19de48ec22c8530aa1.el7ost.noarch
openstack-tripleo-image-elements-0.8.10-19.el7ost.noarch
openstack-tuskar-ui-extras-0.0.3-1.el7ost.noarch
openstack-tuskar-0.4.15-4.el7ost.noarch
openstack-tuskar-ui-0.2.0-11.el7ost.noarch
python-tuskarclient-0.1.15-3.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. In the "Overview" page, drag some of the roles out of the deployment
2. Look near the "Deploy" button, and also look in the "Deployment Roles" page


Actual results:
The unused roles are are associated with the "Unknown" flavor and that causes a warning to be displayed near the "Deploy" button. We don't need a warning about roles we're not interested in.

Comment 3 Ana Krivokapic 2015-02-16 08:46:29 UTC
Upstream patch on review: https://review.openstack.org/#/c/155803/

Comment 4 Ana Krivokapic 2015-03-03 14:12:05 UTC
Merged upstream.

Comment 9 Udi 2015-07-30 14:47:07 UTC
Verified:
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
openstack-tuskar-ui-0.3.0-13.el7ost.noarch

Comment 11 errata-xmlrpc 2015-08-05 13:50:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.