Bug 1192204 - [abrt] python3-dnf: tracer.py:59:transaction:NameError: name 'installed' is not defined
Summary: [abrt] python3-dnf: tracer.py:59:transaction:NameError: name 'installed' is n...
Status: CLOSED DUPLICATE of bug 1187763
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf-plugins-extras
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f286a1152b19d95144150e6850e...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-12 21:12 UTC by Dan Mossor [danofsatx]
Modified: 2015-05-15 08:31 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-02-13 14:59:18 UTC


Attachments (Terms of Use)
File: backtrace (1.25 KB, text/plain)
2015-02-12 21:12 UTC, Dan Mossor [danofsatx]
no flags Details
File: environ (2.11 KB, text/plain)
2015-02-12 21:12 UTC, Dan Mossor [danofsatx]
no flags Details

Description Dan Mossor [danofsatx] 2015-02-12 21:12:46 UTC
Description of problem:
dnf-3 install dia

Version-Release number of selected component:
python3-dnf-0.6.3-2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python3 -OO /bin/dnf-3 install dia
executable:     /bin/dnf-3
kernel:         3.18.6-200.fc21.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
tracer.py:59:transaction:NameError: name 'installed' is not defined

Traceback (most recent call last):
  File "/bin/dnf-3", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 160, in resolving
    base.do_transaction()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 221, in do_transaction
    self.plugins.run_transaction()
  File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 82, in fn
    dnf.util.mapall(operator.methodcaller(method), self.plugins)
  File "/usr/lib/python3.4/site-packages/dnf/util.py", line 157, in mapall
    return list(map(fn, *seq))
  File "/usr/lib/python3.4/site-packages/dnf-plugins/tracer.py", line 59, in transaction
    args = ["tracer", "-n"] + list(installed | erased)
NameError: name 'installed' is not defined

Local variables in innermost frame:
self: <dnf.plugin.dynamic.tracer.Tracer object at 0x7fc44b63aa20>

Comment 1 Dan Mossor [danofsatx] 2015-02-12 21:12:48 UTC
Created attachment 991148 [details]
File: backtrace

Comment 2 Dan Mossor [danofsatx] 2015-02-12 21:12:49 UTC
Created attachment 991149 [details]
File: environ

Comment 3 Radek Holy 2015-02-13 14:59:18 UTC
I'm pretty sure this is a duplicate of bug 1187763.

*** This bug has been marked as a duplicate of bug 1187763 ***


Note You need to log in before you can comment on or make changes to this bug.