Bug 1192259 - Anaconda text install doesn't update spoke status
Summary: Anaconda text install doesn't update spoke status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Samantha N. Bueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F22FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-13 01:15 UTC by Mike Ruckman
Modified: 2015-03-07 00:06 UTC (History)
8 users (show)

Fixed In Version: anaconda-22.20.2-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-07 00:06:05 UTC


Attachments (Terms of Use)

Description Mike Ruckman 2015-02-13 01:15:59 UTC
Description of problem:
After an installation source fails the check, reverting to "Closest Mirror" doesn't clear the error. Re-choosing your software selection *seems* to work, but I can't get it to complete an install after introducing on error in the config.

Version-Release number of selected component (if applicable):
anaconda-22.18-1

How reproducible:
Always

Steps to Reproduce:
1. Boot into a text installation
2. Enter bad url for installation source
3. Watch it fail the check
4. Revert back to "Closest Mirror"

Actual results:
Error never clears and you can't continue the installation

Expected results:
Error clears with new setting, installation can continue

Additional info:
Tested this several times in an x86_64 kvm instance.

Comment 1 David Shea 2015-02-13 12:39:52 UTC
Do you mean that the status doesn't update automatically when the source status changes? Does the status update when you hit r to refresh? The TUI isn't a ncurses interface. It's intended as line-based output so it can be run all sorts of annoyingly simple terminals.

Comment 2 Mike Ruckman 2015-02-13 16:08:18 UTC
The status doesn't update when you change the setting in question or when you refresh the view. Once that error shows up, it seems to stay there.

Comment 3 Fedora Blocker Bugs Application 2015-02-13 21:36:08 UTC
Proposed as a Blocker for 22-final by Fedora user roshi using the blocker tracking app because:

 I believe this bug is a conditional violation of the "Installation interfaces" Final criterion: "The installer must be able to complete an installation using all supported interfaces. "

Comment 4 Adam Williamson 2015-02-16 17:54:14 UTC
Discussed at 2015-02-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-02-16/f22-blocker-review.2015-02-16-17.30.log.txt . Accepted as a Final blocker as a conditional violation of the criterion cited in c#3 - any encounter of an error condition during a text install seems to be unrecoverable.

Comment 5 Samantha N. Bueno 2015-03-02 18:34:53 UTC
Changing the version on this since it's been accepted as an F22 blocker.

Also, pushed the patch which should fix this, to f22-branch and master.

Comment 6 Fedora Update System 2015-03-03 23:33:53 UTC
python-blivet-1.0.1-1.fc22, anaconda-22.20.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.2-1.fc22,python-blivet-1.0.1-1.fc22

Comment 7 Fedora Update System 2015-03-04 21:08:16 UTC
Package python-blivet-1.0.1-1.fc22, anaconda-22.20.2-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-1.0.1-1.fc22 anaconda-22.20.2-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-3110/anaconda-22.20.2-1.fc22,python-blivet-1.0.1-1.fc22
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2015-03-05 00:07:34 UTC
anaconda-22.20.3-1.fc22, python-blivet-1.0.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-blivet-1.0.2-1.fc22,anaconda-22.20.3-1.fc22

Comment 9 Fedora Update System 2015-03-05 14:09:09 UTC
anaconda-22.20.2-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/anaconda-22.20.2-1.fc22

Comment 10 Fedora Update System 2015-03-07 00:06:05 UTC
anaconda-22.20.2-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.