Bug 1192287 - dnf does not handle virtual provides correctly
Summary: dnf does not handle virtual provides correctly
Status: CLOSED DUPLICATE of bug 1154202
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-13 04:38 UTC by Parag Nemade
Modified: 2015-03-05 15:24 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2015-03-05 15:24:08 UTC


Attachments (Terms of Use)

Description Parag Nemade 2015-02-13 04:38:12 UTC
Description of problem:
The text-www-browser is a virtual provide used by text based browsers. I want to remove all such text browsers so I issued command


$ sudo dnf remove text-www-browser
Dependencies resolved.
================================================================================
 Package       Arch          Version                       Repository      Size
================================================================================
Installing:
 elinks        x86_64        0.12-0.42.pre6.fc21           fedora         891 k
Removing:
 links         x86_64        1:2.8-4.fc21                  @System        3.1 M

Transaction Summary
================================================================================
Install  1 Package
Remove   1 Package

Total download size: 891 k
Is this ok [y/N]: n

So, dnf is not removing all packages that provides text-www-browser whereas yum removes it happily.

Version-Release number of selected component (if applicable):
dnf-0.6.3-2.fc21.noarch

How reproducible:
always 

yum and dnf should behave same here right?

Comment 1 Honza Silhan 2015-03-05 15:24:08 UTC
Thanks for the report, we plan to fix this and we are thinking about the new command-name because we would like to preserve this dnf behavior too.

*** This bug has been marked as a duplicate of bug 1154202 ***


Note You need to log in before you can comment on or make changes to this bug.