Bug 119231 - USB removal causes kernel problems
USB removal causes kernel problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-26 14:57 EST by Konstantin Ryabitsev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-05 10:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Ryabitsev 2004-03-26 14:57:16 EST
Description of problem:
I am seeing the following issue: after I unmount and remove the USB
key drive, the USB stack crashes shortly after that (usually
coinciding with exiting and restarting X). The trace this generates
follows:

Mar 24 17:20:32 hagrid kernel: usb 1-1: USB disconnect, address 4
Mar 24 17:20:47 hagrid gconfd (icon-31893): Exiting
Mar 24 17:20:47 hagrid gdm(pam_unix)[31812]: session closed for user icon
Mar 24 17:20:49 hagrid kernel: irq 10: nobody cared! (screaming
interrupt?)
Mar 24 17:20:49 hagrid kernel: Call Trace:
Mar 24 17:20:49 hagrid kernel:  [<0210f1e9>] __report_bad_irq+0x2b/0x67
Mar 24 17:20:49 hagrid kernel:  [<0210f281>] note_interrupt+0x43/0x66
Mar 24 17:20:49 hagrid kernel:  [<0210f714>] do_IRQ+0x248/0x303
Mar 24 17:20:49 hagrid kernel:  [<0212b3bc>] __do_softirq+0x2c/0x73
Mar 24 17:20:49 hagrid kernel:  [<021103d0>] do_softirq+0x46/0x4d
Mar 24 17:20:49 hagrid kernel:  =======================
Mar 24 17:20:49 hagrid kernel:  [<0210f7c3>] do_IRQ+0x2f7/0x303
Mar 24 17:20:49 hagrid kernel:
Mar 24 17:20:49 hagrid kernel: handlers:
Mar 24 17:20:49 hagrid kernel: [<32850017>] (usb_hcd_irq+0x0/0x4b
[usbcore])
Mar 24 17:20:49 hagrid kernel: [<32850017>] (usb_hcd_irq+0x0/0x4b
[usbcore])
Mar 24 17:20:49 hagrid kernel: Disabling IRQ #10

Nothing USB works after this (including my mouse), and X hangs. I have
to reboot in order to be able to do something.

Version-Release number of selected component (if applicable):
kernel-0:2.6.3-2.1.253.2.1.i686

How reproducible:
Always.

Steps to Reproduce:
1. Unmount USB key drive
2. Remove USB key drive
3. Log out
4. Mouse no longer works, and nothing US either.
5. X is unkillable (-9 included)
6. Reboot.
Comment 1 Konstantin Ryabitsev 2004-03-26 23:43:53 EST
Hmm... Correction. It occurred today again, but this time behavior was
different. I unmounted the key-drive, then exited X, then disconnected
the drive. As you can see from the following trace, the problem
occurred right after gdm closed my session.

Removal doesn't seem to matter. I'll do some more testing on Monday.

Mar 26 17:03:21 hagrid gdm(pam_unix)[27958]: session closed for user icon
Mar 26 17:03:24 hagrid kernel: irq 10: nobody cared! (screaming
interrupt?)
Mar 26 17:03:24 hagrid kernel: Call Trace:
Mar 26 17:03:24 hagrid kernel:  [<0210f1e9>] __report_bad_irq+0x2b/0x67
Mar 26 17:03:24 hagrid kernel:  [<0210f281>] note_interrupt+0x43/0x66
Mar 26 17:03:24 hagrid kernel:  [<0210f714>] do_IRQ+0x248/0x303
Mar 26 17:03:24 hagrid kernel:  [<0212b3bc>] __do_softirq+0x2c/0x73
Mar 26 17:03:24 hagrid kernel:  [<021103d0>] do_softirq+0x46/0x4d
Mar 26 17:03:24 hagrid kernel:  =======================
Mar 26 17:03:24 hagrid kernel:  [<0210f7c3>] do_IRQ+0x2f7/0x303
Mar 26 17:03:24 hagrid kernel:
Mar 26 17:03:24 hagrid kernel: handlers:
Mar 26 17:03:24 hagrid kernel: [<32850017>] (usb_hcd_irq+0x0/0x4b
[usbcore])
Mar 26 17:03:24 hagrid kernel: [<32850017>] (usb_hcd_irq+0x0/0x4b
[usbcore])
Mar 26 17:03:24 hagrid kernel: Disabling IRQ #10
Mar 26 17:03:24 hagrid kernel: agpgart: Found an AGP 2.0 compliant
device at 000Mar 26 17:03:24 hagrid kernel: agpgart: Putting AGP V2
device at 0000:00:00.0 inMar 26 17:03:24 hagrid kernel: agpgart:
Putting AGP V2 device at 0000:01:00.0 inMar 26 17:03:35 hagrid kernel:
usb 1-1: USB disconnect, address 4
Comment 2 Konstantin Ryabitsev 2004-03-30 17:14:58 EST
Hmm... Further adjusting this, today this happened even without using
the USB key drive.

It seems that having a USB mouse is enough. Logging out from my gnome
session seems to be sufficient to trigger the trace. 

It also occurs with 2.6.4-1.298.
Comment 3 John Franks 2004-04-01 10:33:06 EST
I am seeing the same problem on a Sony Vaio.  It occurs with
kernel-2.6.3-2.1.253.2.1 and other 2.6.3-2.X and at least some 2.6.4-X
versions -- I haven't tried the very newest.
kernel-2.6.3-1.X seems fine.

Booting seems fine and gdm runs.  Login is fine, but any exiting of
X11 causes a hard lock.  E.g. any of the following will trigger it:
logout, switch to console (ctl-alt-F2), ctl-alt-backspace, telinit 3,
/usr/bin/poweroff.  I am using the x11-org and gdm from the development
tree.

Comment 4 John Franks 2004-04-01 10:34:15 EST
I should have said, I am not sure this is related to USB, but more
likely related to X.
Comment 5 Konstantin Ryabitsev 2004-05-05 10:14:15 EDT
I've not seen this happen in newer kernels, so I'm a happy camper.
This bug can be closed, unless John is still seeing this.
Comment 6 Pete Zaitcev 2004-05-05 10:34:55 EDT
This is a symptom caused by several root causes, essentially
whenever a driver fails to consume an interrupt, so John needs
to file his own. Closing...

Note You need to log in before you can comment on or make changes to this bug.