Bug 119243 - When creating LVM on RAID partitions the anaconda-ks.cfg is invalid
Summary: When creating LVM on RAID partitions the anaconda-ks.cfg is invalid
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-27 01:03 UTC by Steve Bonds
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 05:39:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:417 normal SHIPPED_LIVE Updated grub, parted, rhpl and anaconda packages 2004-09-02 04:00:00 UTC

Description Steve Bonds 2004-03-27 01:03:18 UTC
Description of problem: When creating LVM on RAID partitions the
anaconda-ks.cfg is invalid.  In particular, the "raid pv.20 --fstype
physical volume (LVM) --level=RAID1 raid.17 raid.18" line that was
created should have had the fstype quoted since it contains embedded
spaces.


Version-Release number of selected component (if applicable):
anaconda-9.1.1-7.RHEL

How reproducible: Every time


Steps to Reproduce:
1. Boot ES 3.1 Update 1 from CD on a system with 2 physical hard
drives (VMWare comes in handy here)
2. continue up to the point where disk partitioning takes place
3. choose "partition manually with disk driud"
4. create 2 100MB "Linux RAID" partitions for /boot, one on each
physical drive
5. create 2 more "Linux RAID" partitions, as large as possible, one on
each physical drive
6. create /dev/md0 for /boot
7. create /dev/md1 and assign it to be an LVM physical volume
8. create an LVM VG and make / and swap as logical volumes
9. continue the install
10. once the system reboots, check the /root/anaconda-ks.cfg file

  
Actual results:
The anaconda-ks.cfg file contains a line:

#raid pv.20 --fstype physical volume (LVM) --level=RAID1 raid.17 raid.18

Which does not serve as a good example to use for a real kickstart.

Expected results:

The line should be:

#raid pv.20 --fstype "physical volume (LVM)" --level=RAID1 raid.17 raid.18

(Note the inclusion of quotes)

Additional info:

Comment 1 Steve Bonds 2004-03-27 01:04:26 UTC
In step 1, that should be:

1. Boot ES 3 Update 1 from CD

Since there is no ES 3.1.  ;-)

Comment 2 Jeremy Katz 2004-06-09 21:36:04 UTC
Fixed in CVS for Update 3.

Comment 3 John Flanagan 2004-09-02 05:39:50 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-417.html



Note You need to log in before you can comment on or make changes to this bug.