Bug 119253 - gnome-session fails on "log out" menu activation
gnome-session fails on "log out" menu activation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-27 14:47 EST by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.4.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-08 16:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" | sort -u (20.80 KB, text/plain)
2004-03-27 14:48 EST, Moritz Barsnick
no flags Details
Output from rpm -qa --queryformat='%{INSTALLTIME}\t%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n' | sort -n | tail -201 (7.05 KB, text/plain)
2004-03-27 14:52 EST, Moritz Barsnick
no flags Details

  None (edit)
Description Moritz Barsnick 2004-03-27 14:47:38 EST
Description of problem:
Choosing the "Log Out" menu item (main Gnome menu) recently crashes 
gnome-session (returns to chooser) instead of giving "log out"/"shut 
down"/"reboot" options.

Version-Release number of selected component (if applicable):
2.4.0-1

How reproducible:
always

Steps to Reproduce:
1. Choose Gnome menu item "Log Out"
2.
3.
  
Actual results:
(gnome-session:1908): GLib-GObject-WARNING **: g_object_set_valist: 
construct property "type" for object `GtkDialog' can't be set after 
construction
The program 'gnome-session' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1396 error_code 8 request_code 42 minor_code 0)
  (Note to programmers: normally, X errors are reported 
asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() 
function.)


Expected results:
Choice window "log out"/"shut down"/"reboot" appears.

Additional info:
Very important info: I've been updating my FC1 from 
Fedora-development every once in a while on interesting packages, but 
recently chickened out on the Gnome-2.5 updates. I had some problem 
with gtk2-2.4.0, so I reverted that.

I assume I've done some package update which clashes with 
gnome-session.

I don't know how to run gnome-session with "--sync".

I'm attaching my (censored ;->) list of installed packages and a 
sorted list showing my recently installed packages.

Thanks,
Moritz
Comment 1 Moritz Barsnick 2004-03-27 14:48:47 EST
Created attachment 98903 [details]
Output from rpm -qa --qf "%{name}-%{version}-%{release}.%{arch}\n" | sort -u
Comment 2 Moritz Barsnick 2004-03-27 14:52:54 EST
Created attachment 98904 [details]
Output from rpm -qa --queryformat='%{INSTALLTIME}\t%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n' | sort -n | tail -201
Comment 3 Mark McLoughlin 2004-03-29 02:27:25 EST
Your glib 2.4.0 is conflicting with gnome-session 2.4.0. I'll do a
gnome-session errata this week with a fix.
Comment 4 Moritz Barsnick 2004-03-29 05:59:52 EST
Hmm, since www.gtk.org claims gtk+2 and glib2 to be binary 
compatible, I wouldn't have expected this. ;-)

Otherwise, the likely result would've been NOTABUG, since I'm doing 
partial updates, and you can't predict things like "Conflicts: glib 
>= 2.3.x" when 2.2 is current. ;-) I just wanted to know which 
component was messing it up for me. (My Bluecurve theme has also 
mysteriously disappeared, I think.)

Thanks,
Moritz
Comment 5 Mark McLoughlin 2004-03-29 11:05:22 EST
Well, gtk2/glib2 *are* binary compatible but not to the point of
working around bugs in applications. This is a gnome-session bug, but
it is only triggered by glib 2.4.0.

The bluecurve thing you're seeing is because the location of theme
engines has change with gtk 2.4.0 (or something). You need a new
redhat-artwork to go with it, basically.
Comment 6 Mark McLoughlin 2004-03-30 14:43:09 EST
Moritz: could you try rebuilding this and see if it fixes the logout
dialog problem with glib-2.6 installed:

http://people.redhat.com/markmc/gnome-session-2.4.0-3.src.rpm

(rebuild with "rpm --rebuild gnome-session-2.4.0-3.src.rpm")

Please let me know if it works for you and I'll release an errata
straight away
Comment 7 Moritz Barsnick 2004-03-30 15:56:22 EST
Thanks Mark! Built fine, installed fine, and now, after an X11 
restart, the "Log Out" menu works as expected. Haven't checked much 
else though.

I very much assume you mean glib-2.4 and not glib-2.6!?

PROMPT> rpm -qa | egrep "^(glib-|gtk2-)" | sort
glib2-2.4.0-1
glib2-devel-2.4.0-1
gtk2-2.2.4-5.2
gtk2-devel-2.2.4-5.2
gtk2-engines-2.2.0-3

If you release an errata, I'll gladly approve a "Closed (Errata)".
:-)


(Now I found something minor in gnome-panel ... gotta run! ;->)
Comment 8 Moritz Barsnick 2004-04-08 16:10:44 EDT
Thank you, closed!

Note You need to log in before you can comment on or make changes to this bug.