Bug 1192619 - Found HC with no IRQ. Check BIOS/PCI. init fail, -19 Boot errors.
Summary: Found HC with no IRQ. Check BIOS/PCI. init fail, -19 Boot errors.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1192620 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-13 20:57 UTC by Brian Monroe
Modified: 2015-09-04 02:56 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-04 02:56:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Brian Monroe 2015-02-13 20:57:11 UTC
Description of problem:
I'm getting a boot error when I boot any F21 kernel on my laptop. 


How reproducible:
Always. 

Steps to Reproduce:
1.reboot
2.Try to frantically write down the error code. 
3.Remember you have a camera and snap a picture. 

Actual results:
[     0.541542] uhci_hcd 0000:00:1a.0: Found HC with no IRQ. Check BIOS/PCI 0000:00:1a.0 setup!
[     0.541585] uhci_hcd 0000:00:1a.0: init 0000:00:1a.0 fail, -19
[     0.541616] uhci_hcd 0000:00:1d.0: Found HC with no IRQ. Check BIOS/PCI 0000:00:1d.0 setup!
[     0.541649] uhci_hcd 0000:00:1d.0: init 0000:00:1d.0 fail, -19

Expected results:
no errors

Additional info:
Looking into some google results it looks like it might be related to this issue here: https://ask.fedoraproject.org/en/question/27476/f18-on-macbook-pro-2010-2-external-monitors-crashing/ from a few years ago. I'll list the lspci output in a bit.

Comment 1 Brian Monroe 2015-02-13 21:00:43 UTC
lspci output: 
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 18)
00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 18)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 18)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1a.7 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06)
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB Universal Host Controller (rev 06)
00:1d.7 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GT216M [GeForce GT 330M] (rev a2)
01:00.1 Audio device: NVIDIA Corporation GT216 HDMI Audio Controller (rev a1)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5764M Gigabit Ethernet PCIe (rev 10)
03:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)
04:00.0 FireWire (IEEE 1394): LSI Corporation FW643 [TrueFire] PCIe 1394b Controller (rev 08)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation 1st Generation Core Processor QPI Physical 0 (rev 05)
ff:02.2 Host bridge: Intel Corporation 1st Generation Core Processor Reserved (rev 05)
ff:02.3 Host bridge: Intel Corporation 1st Generation Core Processor Reserved (rev 05)

Comment 2 Brian Monroe 2015-02-13 21:01:21 UTC
*** Bug 1192620 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Kernel Team 2015-04-28 18:31:27 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.19.5-200.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 22, and are still experiencing this issue, please change the version to Fedora 22.

If you experience different issues, please open a new bug report for those.

Comment 4 Brian Monroe 2015-04-28 19:27:17 UTC
This bug is still persistent in kernel 3.19.5-200.fc21

As an FYI - This bug is -NOT- persistent with a reboot command. However, when my computer reboots when I choose 'shutdown' (see bug 1168557) it's still persistent. It might be possible that they're related.

Comment 5 David Kaylor 2015-08-06 00:23:11 UTC
I was seeing the same thing on a 2010 MacBook Pro. Pressing escape showed me my luks password prompt and I was able to boot. The following kernel parameter fixed the issue for me:

video=efifb

I still see the error briefly before the graphical boot starts, but everything seems to be working.

Comment 6 Brian Monroe 2015-09-04 02:56:48 UTC
I can't replicate this bug after updating to the new kernel in Fedora 22 so I'm going to close this.


Note You need to log in before you can comment on or make changes to this bug.