Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1192702 - ImportError: cannot import name storageInitialize
Summary: ImportError: cannot import name storageInitialize
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:452f3595d1c00bb42dde46989fc...
: 1197431 (view as bug list)
Depends On:
Blocks: F22AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2015-02-14 13:41 UTC by Joachim Frieben
Modified: 2015-03-02 19:01 UTC (History)
19 users (show)

Fixed In Version: anaconda-22.20-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 19:29:24 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (114.36 KB, text/plain)
2015-02-14 13:41 UTC, Joachim Frieben
no flags Details
File: anaconda.log (2.46 KB, text/plain)
2015-02-14 13:41 UTC, Joachim Frieben
no flags Details
File: dnf.log (853 bytes, text/plain)
2015-02-14 13:41 UTC, Joachim Frieben
no flags Details
File: environ (492 bytes, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: lsblk_output (1.44 KB, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: nmcli_dev_list (1.00 KB, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: os_info (443 bytes, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: program.log (4.40 KB, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: storage.log (557 bytes, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: syslog (81.03 KB, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
File: ifcfg.log (2.10 KB, text/plain)
2015-02-14 13:42 UTC, Joachim Frieben
no flags Details
MATE install errors 20150214 (2.78 MB, image/jpeg)
2015-02-14 17:13 UTC, satellitgo
no flags Details

Description Joachim Frieben 2015-02-14 13:41:53 UTC
Version-Release number of selected component:
anaconda-22.19-1

The following was filed automatically by anaconda:
anaconda 22.19-1 exception report
Traceback (most recent call first):
  File "/sbin/anaconda", line 1308, in <module>
    from blivet import storageInitialize
ImportError: cannot import name storageInitialize

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-x86_64 rd.live.check quiet
dnf.rpm.log:    Feb 14 13:37:02 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
product:        Fedora"
release:        Cannot get release name.
type:           anaconda
version:        Fedora

Comment 1 Joachim Frieben 2015-02-14 13:41:56 UTC
Created attachment 991711 [details]
File: anaconda-tb

Comment 2 Joachim Frieben 2015-02-14 13:41:58 UTC
Created attachment 991712 [details]
File: anaconda.log

Comment 3 Joachim Frieben 2015-02-14 13:41:59 UTC
Created attachment 991713 [details]
File: dnf.log

Comment 4 Joachim Frieben 2015-02-14 13:42:01 UTC
Created attachment 991714 [details]
File: environ

Comment 5 Joachim Frieben 2015-02-14 13:42:02 UTC
Created attachment 991715 [details]
File: lsblk_output

Comment 6 Joachim Frieben 2015-02-14 13:42:03 UTC
Created attachment 991716 [details]
File: nmcli_dev_list

Comment 7 Joachim Frieben 2015-02-14 13:42:04 UTC
Created attachment 991717 [details]
File: os_info

Comment 8 Joachim Frieben 2015-02-14 13:42:06 UTC
Created attachment 991718 [details]
File: program.log

Comment 9 Joachim Frieben 2015-02-14 13:42:07 UTC
Created attachment 991719 [details]
File: storage.log

Comment 10 Joachim Frieben 2015-02-14 13:42:10 UTC
Created attachment 991720 [details]
File: syslog

Comment 11 Joachim Frieben 2015-02-14 13:42:11 UTC
Created attachment 991721 [details]
File: ifcfg.log

Comment 12 Richard S. Hendershot 2015-02-14 13:48:14 UTC
Another user experienced a similar problem:

boot.iso running in virtualbox.  anaconda fails to start X. choose text mode

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-i386 quiet
dnf.rpm.log:    Feb 14 13:43:56 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.i686
package:        anaconda-22.19-1
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Cannot get release name.
version:        Fedora

Comment 13 satellitgo 2015-02-14 16:28:30 UTC
Another user experienced a similar problem:

start anaconda 22.19-1 in mate 20150214

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-x86_64-22-20150 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-core-22.19-1.fc22.x86_64
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 14 satellitgo 2015-02-14 16:32:34 UTC
Another user experienced a similar problem:

try to install mate to disk with anaconda22.19-1 from live install icon

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-MATE-x86_64-22-20150 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-core-22.19-1.fc22.x86_64
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 15 satellitgo 2015-02-14 16:49:19 UTC
Another user experienced a similar problem:

liveinst in Soas 20150214 x86_64 in f21Boxes

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-SoaS-x86_64-22-20150 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-core-22.19-1.fc22.x86_64
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 16 satellitgo 2015-02-14 17:13:25 UTC
Created attachment 991758 [details]
MATE install errors 20150214

Comment 17 satellitgo 2015-02-14 17:46:01 UTC
Another user experienced a similar problem:

a  booted dd USB of workstation 20150214 x86_64;  install to Hard Disk clicked

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-2015021 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-core-22.19-1.fc22.x86_64
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 18 Adam Williamson 2015-02-14 18:32:46 UTC
Looks like a pretty obvious Alpha blocker.

Comment 19 Shawn Starr 2015-02-14 21:01:39 UTC
Another user experienced a similar problem:

This is a negative case, if the kickstart file has 'sda' for device name and you're using a KVM VM to install with which uses 'vda' blivet freaks out with an 'Unknown Error'.

Maybe better to say device isn't found vs a stack dump?

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   initrd=initrd-x86_64.img ip=dhcp slub_debug=- ks=ftp://172.18.2.4/ks.cfg inst.repo=https://dl.fedoraproject.org/pub/fedora/linux/development/22/x86_64/os/ zswap.enabled=1 cgroup_disable=memory zswap.zpool=zsmalloc BOOT_IMAGE=vmlinuz-x86_64 
dnf.rpm.log:    Feb 14 20:55:25 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-22.19-1
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Cannot get release name.
version:        Fedora

Comment 20 joerg.lechner 2015-02-15 08:52:20 UTC
Another user experienced a similar problem:

Successful download of F22 LXDE ISO produced on 2015 02 14. System used F21. liveusbcreator successful transfer to usb flash media. Installation on external pata disk, connected via usb, failed.

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-LXDE-x86_64-22-20150 ro rd.live.image quiet rhgb
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-core-22.19-1.fc22.x86_64
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 21 satellitgo 2015-02-15 13:16:26 UTC
Another user experienced a similar problem:

branched boot.iso x86_64 20150215 in f21 boxes

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-x86_64 quiet
dnf.rpm.log:    Feb 15 13:14:31 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-22.19-1
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Cannot get release name.
version:        Fedora

Comment 22 Vratislav Podzimek 2015-02-16 08:01:08 UTC
This is caused by anaconda and blivet being out of sync. I have a patch for this ready, but I didn't want to push it before new blivet was available since it wouldn't work with the old blivet.

Comment 23 Vratislav Podzimek 2015-02-16 08:13:53 UTC
https://vpodzime.fedorapeople.org/1192702_updates.img

Comment 24 Fabian Deutsch 2015-02-16 09:00:22 UTC
I also ran into this.

Comment 25 Fabian Deutsch 2015-02-16 09:04:07 UTC
Using the update from comment 23 fixes this issue for me.

Comment 26 Lukas Brabec 2015-02-16 09:04:17 UTC
Another user experienced a similar problem:

Tried to boot 22_Branched_20150214_x86_64.iso

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-x86_64 quiet
dnf.rpm.log:    Feb 16 09:02:09 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-22.19-1
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Cannot get release name.
version:        Fedora

Comment 27 Lukas Brabec 2015-02-16 09:11:59 UTC
(In reply to Vratislav Podzimek from comment #23)
> https://vpodzime.fedorapeople.org/1192702_updates.img

works for me

Comment 28 Adam Williamson 2015-02-16 17:41:29 UTC
Discussed at 2015-02-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2015-02-16/f22-blocker-review.2015-02-16-17.30.log.txt . Accepted as a blocker as a clear violation of Alpha criterion "The installer must run when launched normally from the release-blocking images".

Comment 29 Chuck Forsberg 2015-02-16 22:37:47 UTC
Another user experienced a similar problem:

Cannot test new Fedora versions when the installer is profounfly broken for days at a time.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   initrd=initrd.img ramdisk_size=9216 root=live:http://192.168.1.13/squashfs.img repo=http://192.168.1.13/rawhide/os BOOT_IMAGE=vmlinuz 
dnf.rpm.log:    Feb 16 14:35:59 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-22.19-1
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Cannot get release name.
version:        Fedora

Comment 30 David Terrey 2015-02-16 23:47:08 UTC
(In reply to Vratislav Podzimek from comment #23)
> https://vpodzime.fedorapeople.org/1192702_updates.img

This is how to get this working for those that are unsure.

1: Boot up iso image

2: When it gives you the choice to Install Fedora Rawhide, Test media or troubleshoot. Press the TAB key.

3: It will display the Startup config for vmlinux. Type this: 
linux updates=https://vpodzime.fedorapeople.org/1192702_updates.img

4: Hit enter and it will boot up and you can continue with the install.

Comment 31 Pavel Zhukov 2015-02-17 10:35:12 UTC
Another user experienced a similar problem:

Start xfce live CD. Click "Install".

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-Xfce-i686-22-2015021 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.i686
package:        anaconda-core-22.19-1.fc22.i686
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 32 Mike Chambers 2015-02-17 13:57:04 UTC
Another user experienced a similar problem:

1 - Create boot cd from the boot.iso
2 - booted cd with nfs paramater at startup to perform nfs install
3 - Wait for installer to start, but doesn't and gets this error.

addons:         com_redhat_kdump
cmdline:        /usr/bin/python2  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-22-x86_64 repo=nfs:scooby:/rsync/fedora-test/release
dnf.rpm.log:    Feb 17 07:53:09 INFO --- logging initialized ---
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-22.19-1
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Cannot get release name.
version:        Fedora

Comment 33 satellitgo 2015-02-17 15:53:17 UTC
20150217 Branched boot.iso x86_64  is 22.20-1  seems to have resolved this in f21 Boxes. But only server and minimal look like they pass checking. Minimal installs and logs in to user.

Comment 34 antonis.v2mania 2015-02-20 09:02:12 UTC
Another user experienced a similar problem:

anaconda 22.19-1 exception report
Traceback (most recent call first):
  File "/sbin/anaconda", line 1308, in <module>
    from blivet import storageInitialize
ImportError: cannot import name storageInitialize

cmdline:        /usr/bin/python2  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-22-2015021 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
hashmarkername: anaconda
kernel:         3.20.0-0.rc0.git5.1.fc22.x86_64
package:        anaconda-core-22.19-1.fc22.x86_64
packaging.log:  
product:        Fedora"
reason:         ImportError: cannot import name storageInitialize
release:        Fedora release 22 (Twenty Two)
version:        Fedora

Comment 35 satellitgo 2015-03-01 19:44:58 UTC
seems fixed in 22.20.1-1

Comment 36 David Shea 2015-03-02 14:33:47 UTC
*** Bug 1197431 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.