Bug 119271 - Lack of "class" overrides stop UART/serial_cs-based Bluetooth cards working
Lack of "class" overrides stop UART/serial_cs-based Bluetooth cards working
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-28 08:07 EST by Matt Dainty
Modified: 2015-01-04 17:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 05:55:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Dainty 2004-03-28 08:07:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The bluez-utils package adds /etc/pcmcia/bluetooth and
/etc/pcmcia/bluetooth.conf to the pcmcia-cs package so that Bluetooth
PCMCIA devices get correctly set up.

Because some bluetooth cards behave like serial ports, with no
additional help cardmgr will set them up as such, so functionality was
added to give the facility for a card's class to be overridden, like so:

card "Bluetooth Serial Card"
  manfid 0x1234, 0x5678
  bind "serial_cs" class "bluetooth"

The bluetooth.conf file added by the bluez-utils package originally
had this functionality added, but because the version of pcmcia-cs
currently used is too old, this extra class override has been removed
via a patch in the bluez-utils .spec file to prevent cardmgr
complaining when sourcing this file on startup.

This functionality was apparently added to the pcmcia-cs package in
version 3.2.1 released August 2002 (from the source changelog). Please
can either this class override functionality be backported into the
current pcmcia-cs package or the base version used instead be updated
to 3.2.1 or newer?

Currently, when I insert my H4 mode Brainboxes BL-500, it gets
detected and set up as a serial port, if I then perform the steps that
the /etc/pcmcia/bluetooth script would do, (ie. run hciattach), then
the card works and behaves correctly as it should with the rest of the
Fedora Bluetooth packages, so this fix would make the card work
automatically.

Version-Release number of selected component (if applicable):
kernel-pcmcia-cs-3.1.31-16

How reproducible:
Always

Steps to Reproduce:
1. Insert a UART-based (serial_cs driver) PCMCIA card
2. Examine /var/log/messages    

Actual Results:  Log messages show the card is handed to the PCMCIA
serial subsystem and set up as standard serial port

Expected Results:  Log messages should show the card handed to the
PCMCIA bluetooth subsystem and set up as a serial port followed by
hciattach to attach the device into the running bluetooth daemons.

Additional info:
Comment 2 David Woodhouse 2005-01-11 05:37:44 EST
We have pcmcia-cs-3.2.7 in FC3. It ought to be fine.
Comment 3 Matt Dainty 2005-01-11 05:55:28 EST
Yes, I imagine it is. The bug was originally and specifically against
FC1 so I'm not sure why it was reclassified against FC2 or FC3. I
imagine this won't ever get fixed in FC1 (I'm not running it anywhere
now) so it's pointless keeping this bug new/open.

Note You need to log in before you can comment on or make changes to this bug.