Bug 1192724 - openvpn failed to start with option cipher none
Summary: openvpn failed to start with option cipher none
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: openvpn
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: David Sommerseth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-14 18:14 UTC by capuzzi
Modified: 2017-04-24 19:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-24 19:16:04 UTC


Attachments (Terms of Use)

Description capuzzi 2015-02-14 18:14:15 UTC
Description of problem:

When using the configuration option cipher none the openvpn server crashes on start.

Version-Release number of selected component (if applicable): 
openvpn-2.3.6-1.el6.x86_64


How reproducible:
Always.


Steps to Reproduce:
1. Use option cipher none in config
2. Start openvpn server
3.

Actual results:

Assertion failed at crypto_openssl.c:523
Exiting due to fatal error

Expected results:

As with previous versions, it should just start and wait for clients to connect.

Additional info:

I think this is the bug reported and fixed upstream https://community.openvpn.net/openvpn/ticket/473

changing the option to, e.g, cipher BF-CBC makes openvpn work correctly.

Comment 1 capuzzi 2015-07-06 11:51:01 UTC
Hello,
I've just noticed that the version from beginning of june, openvpn-2.3.7-1.el6 , has solved the problem.
Thanks,
Best regards.


Note You need to log in before you can comment on or make changes to this bug.