Bug 119279 - kernel-2.6.4-1.290 reboots when leaving suspend mode
kernel-2.6.4-1.290 reboots when leaving suspend mode
Status: CLOSED DUPLICATE of bug 117032
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2004-03-28 16:24 EST by cam
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description cam 2004-03-28 16:24:06 EST
kernel-2.6.4-1.290 on hardware that has incomplete support for ACPI;
therefore using apm (apmd-3.0.2-20). Sharp notebook PC-AR50. Kernel
boot arguments ro acpi=off psmouse.proto=imps root=LABEL=/ rhgb
The notebook suspends normally when closing the lid. When opening the
lid the BIOS prompts for the password and when given the machine seems
to exit suspend (eg. HD noises), and immediately reboots. When booting
the ext3 filesystems are recovered and the logs indicate the machine
was not cleanly shut down.

Version-Release number of selected component (if applicable):
happens with kernel-2.6.4-1.290
does not happen with kernel-2.6.1-1.65

How reproducible: every time with the affected kernel on my hardware

Steps to Reproduce:
1. boot affected kernel
2. enter suspend mode
3. attempt to exit suspend mode
Actual results: affected kernel reboots the machine

Expected results: normal exit from suspend

Additional info: I will do any reasonable testing to attempt to
diagnose this bug or test patches/fixes.
Comment 1 J.H. 2004-03-28 19:45:00 EST
I have also had this same problem, but with more than the recent
kernel.  I have seen this with any of the 2.6.x kernel I have used
(both vanilla and redhat / fedora) Upon un-suspend the system does one
of two things

1) Reboots
2) hangs

In the case of a reboot, suspending from a pure console it is possible
to see that the system seems to come out of sleeping, display the old
contents of the console and THAN reboot suddenly.  Also doing some
general prusing this may be related to some changes that happened in
the 2.5.x kernel related to the pci setup and it being lost.  From
those comments it looked like we might be SOL :-(

If there is anything I can do to help with this, let me know as I
really want my laptop to suspend / resume properly!

- John H.

Fujitsu P2040 Laptop
Comment 2 Didier 2004-03-29 06:48:22 EST
, as APM suspend last functioned OK with 2.6.3-1.52 (Dave Jones'
kernel), failed on all RH kernels after that one (4G/4G merge ?).

Symptoms : when resuming after a successful APM suspend, there is some
harddisk activity (nothing gets logged to syslog), and the laptop (IBM
ThinkPad A30p) reboots.

As ACPI sleep (S3) never worked in the past, I'm eagerly awaiting an
RPM with 2.6.5-rc2-mm4 ACPI 4G/4G sleep fixes.
Comment 3 Arjan van de Ven 2004-03-29 06:51:01 EST
unfortionately those are included already but aren't sufficient ;(
Comment 4 Didier 2004-03-29 06:53:34 EST
Additional note : with 2.6.4-1.279, I once (out of approx. 3 or 4
tests) got a kernel OOPS in the ext3 module, immediately following the
APM resume ; nothing was written to syslog, though, and the machine
immediately rebooted thereafter, so no additional info (don't have a
serial console neither).
Comment 5 Bill Nottingham 2004-03-29 16:07:55 EST

*** This bug has been marked as a duplicate of 117032 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:02:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.