Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1192797 - SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file .
Summary: SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file .
Keywords:
Status: CLOSED DUPLICATE of bug 1192795
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4de5adbe7f7f03bd871cd43365b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-15 11:14 UTC by hx
Modified: 2015-02-16 08:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 08:46:15 UTC
Type: ---


Attachments (Terms of Use)

Description hx 2015-02-15 11:14:10 UTC
Description of problem:
SELinux is preventing /usr/sbin/smbd from 'getattr' accesses on the file .

*****  Plugin catchall_boolean (32.5 confidence) suggests   ******************

If you want to allow samba to share any file/directory read only.
Then you must tell SELinux about this by enabling the 'samba_export_all_ro' boolean.
You can read 'iceauth_selinux' man page for more details.
Do
setsebool -P samba_export_all_ro 1

*****  Plugin catchall_boolean (32.5 confidence) suggests   ******************

If you want to allow samba to share users home directories.
Then you must tell SELinux about this by enabling the 'samba_enable_home_dirs' boolean.
You can read 'iceauth_selinux' man page for more details.
Do
setsebool -P samba_enable_home_dirs 1

*****  Plugin catchall_boolean (32.5 confidence) suggests   ******************

If you want to allow samba to share any file/directory read/write.
Then you must tell SELinux about this by enabling the 'samba_export_all_rw' boolean.
You can read 'iceauth_selinux' man page for more details.
Do
setsebool -P samba_export_all_rw 1

*****  Plugin catchall (4.5 confidence) suggests   ***************************

If you believe that smbd should be allowed getattr access on the  file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep smbd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:smbd_t:s0
Target Context                unconfined_u:object_r:iceauth_home_t:s0
Target Objects                 [ file ]
Source                        smbd
Source Path                   /usr/sbin/smbd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           samba-4.1.14-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-196.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.17.6-200.fc20.x86_64 #1 SMP Mon
                              Dec 8 15:21:05 UTC 2014 x86_64 x86_64
Alert Count                   1
First Seen                    2014-12-25 13:51:29 EET
Last Seen                     2014-12-25 13:51:29 EET
Local ID                      2934695c-a181-4eb8-9c5f-9802d4104794

Raw Audit Messages
type=AVC msg=audit(1419508289.487:636): avc:  denied  { getattr } for  pid=5028 comm="smbd" path="/home/linards/.ICEauthority" dev="dm-2" ino=262169 scontext=system_u:system_r:smbd_t:s0 tcontext=unconfined_u:object_r:iceauth_home_t:s0 tclass=file permissive=1


type=SYSCALL msg=audit(1419508289.487:636): arch=x86_64 syscall=newfstatat success=yes exit=0 a0=20 a1=7fd8848d5243 a2=7fffd94f55a0 a3=0 items=0 ppid=2569 pid=5028 auid=4294967295 uid=1000 gid=0 euid=1000 suid=0 fsuid=1000 egid=1000 sgid=0 fsgid=1000 tty=(none) ses=4294967295 comm=smbd exe=/usr/sbin/smbd subj=system_u:system_r:smbd_t:s0 key=(null)

Hash: smbd,smbd_t,iceauth_home_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.12.1-196.fc20.noarch

Additional info:
reporter:       libreport-2.3.0
hashmarkername: setroubleshoot
kernel:         3.18.3-201.fc21.x86_64
type:           libreport

Potential duplicate: bug 845586

Comment 1 Miroslav Grepl 2015-02-16 08:46:15 UTC

*** This bug has been marked as a duplicate of bug 1192795 ***


Note You need to log in before you can comment on or make changes to this bug.