Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1192827 - Wine fails to install on Fedora 21 (libusbx multilib issue)
Summary: Wine fails to install on Fedora 21 (libusbx multilib issue)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-15 17:31 UTC by Valent Turkovic
Modified: 2015-02-17 21:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-15 19:51:20 UTC
Type: Bug


Attachments (Terms of Use)
yum and dnf install log messages (17.43 KB, text/plain)
2015-02-15 17:31 UTC, Valent Turkovic
no flags Details

Description Valent Turkovic 2015-02-15 17:31:48 UTC
Created attachment 991954 [details]
yum and dnf install log messages

Description of problem:
Wine fails to install on Fedora 21

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. use yum or dnf to install wine
2. watch it fail
3.

Actual results:


Expected results:
To have wine installed

Additional info:

Comment 1 Michael Cronenworth 2015-02-15 19:51:20 UTC
libusbx-1.0.19-100.rc2.fc21.x86_64 is not a Fedora package. Please use Fedora packages.

If you're unsure what that package is, please perform a "distro sync" to downgrade to the Fedora version.

Comment 2 Andreas Bierfert 2015-02-15 19:53:24 UTC
This is not a wine bug. As the log points out you have mismatching versions of libusbx installed for i686 and x86_64. I cannot find libusbx-1.0.19-100.rc2.fc21.x86_64 anywhere in the fedora repos/buildsys so downgrading this to the latest release in fedora 21 should do the trick (yum downgrade libusbx.x86_64).

Comment 3 Michael Schwendt 2015-02-15 20:49:56 UTC
> libusbx-1.0.19-100.rc2.fc21.x86_64

Google finds one in spot's fedorapeople repo. Uh oh!

> distro sync

Note that a "yum distro-sync" won't "fix" anything, if the package is included within any enabled repo. You need to disable such an incompatible repo before a distro-sync would replace/downgrade packages.

Comment 4 Valent Turkovic 2015-02-17 21:10:16 UTC
Thanks, I can confirm that by removing chromium package and downgrading libusbx wine installation works as expected. Thank you.


Note You need to log in before you can comment on or make changes to this bug.