Bug 119286 - Allow "rpm -e --prefix ..."
Allow "rpm -e --prefix ..."
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
GinGin64
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-28 21:21 EST by Christian Goetze
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-07 12:54:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Goetze 2004-03-28 21:21:12 EST
Description of problem:

install the same rpm multiple times. There is one legititimate use
case for this, though, namely installing it multiple times using
different --prefix values. In development a case can be made to
support this, since different developers or testers would want to
test a realistic installation scneario in parallel.

To support this one use case, how about extending the
 "name, epoch, version, release, architecture"
with one more component, "prefix". This way, one could address a
specific package instance via --prefix and selectively erase only
the rpm installed at the specified prefix.

Another consideration would be to make it illegal to have the
exact same rpm installed multiple times except if --prefix differs.

Version-Release number of selected component (if applicable):

4.1 and later

How reproducible:

very

Steps to Reproduce:
1. rpm -i <some-rpm>
2. rpm -i --prefix <someplace> <same-rpm>
3. rpm -e --prefix <sameplace> <the-rpm>
  
Actual results:

doesn't work

Expected results:

erases the second package

Additional info:
Comment 1 Jeff Johnson 2004-04-07 12:54:24 EDT
Using --prefix to qualify upgrade/erasure ain't the right thing to do.
Comment 2 Christian Goetze 2004-04-07 13:07:58 EDT
So what is the right thing to do?? How do you selectively erase a 
specific package installed with a specific prefix, if that same 
package is installed multiple times?

Note You need to log in before you can comment on or make changes to this bug.