Bug 1192867 - phatch fails to run with wxPython 3.0 in F22/Rawhide
Summary: phatch fails to run with wxPython 3.0 in F22/Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phatch
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1222263 (view as bug list)
Depends On:
Blocks: DESIGN-SW
TreeView+ depends on / blocked
 
Reported: 2015-02-16 01:25 UTC by Scott Talbert
Modified: 2016-02-01 02:01 UTC (History)
3 users (show)

Fixed In Version: phatch-0.2.7-22.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-30 13:55:39 UTC
Type: Bug


Attachments (Terms of Use)
gtk3 compatibility patch (1.43 KB, patch)
2015-06-28 20:38 UTC, Scott Talbert
no flags Details | Diff

Description Scott Talbert 2015-02-16 01:25:28 UTC
In F22/Rawhide, wxPython has been updated to version 3.0 and is now compiled against GTK+ 3.  Unfortunately, phatch now fails to run:

[talbert@localhost ]$ phatch

(phatch:24533): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/breakpoint trap (core dumped)

This seems to be due to phatch using GTK+ 2 someplace else.  A likely candidate is notify-python.

Comment 1 Luya Tshimbalanga 2015-06-27 06:26:10 UTC
Same problem when attempting to use on Fedora Design Suite.

Comment 2 Scott Talbert 2015-06-28 01:47:18 UTC
OK, I'll try to work on a patch.

Comment 3 Scott Talbert 2015-06-28 20:38:38 UTC
Created attachment 1044100 [details]
gtk3 compatibility patch

OK, here's a patch.  As I suspected, the gtk2 culprit was notify-python.  When applying this patch the notify-python dependency should be replaced by pygobject3-base.  Additionally, this patch from Debian should probably also be applied to fix some other wxPython3 issues:
https://sources.debian.net/src/phatch/0.2.7.1-3.1/debian/patches/wxpy3.0-compat.patch/

Comment 4 Luya Tshimbalanga 2015-07-03 20:18:26 UTC
*** Bug 1222263 has been marked as a duplicate of this bug. ***

Comment 5 Jaromír Cápík 2015-07-07 12:26:11 UTC
Hello Scott.

Thanks for the patch. Gonna look at that shortly.

Comment 6 Jaromír Cápík 2015-07-07 13:45:44 UTC
Thanks a lot, Scott!

The fix is sane and clean.
Going to apply to Rawhide and F22 sources.

Comment 7 Fedora Update System 2015-07-07 16:03:27 UTC
phatch-0.2.7-21.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/phatch-0.2.7-21.fc22

Comment 8 Scott Talbert 2015-07-08 23:50:55 UTC
My pleasure.

One other item related to this patch, you should replace:
Requires: notify-python
with
Requires: pygobject3-base

Comment 9 Fedora Update System 2015-07-10 19:03:04 UTC
Package phatch-0.2.7-21.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing phatch-0.2.7-21.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11235/phatch-0.2.7-21.fc22
then log in and leave karma (feedback).

Comment 10 Jaromír Cápík 2015-07-13 13:45:29 UTC
(In reply to Scott Talbert from comment #8)
> My pleasure.
> 
> One other item related to this patch, you should replace:
> Requires: notify-python
> with
> Requires: pygobject3-base

Argh. The dependency was in the -cli subpackage and I missed that. Gonna fix.

Comment 11 Fedora Update System 2015-07-14 15:48:04 UTC
phatch-0.2.7-21.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-07-14 21:31:23 UTC
phatch-0.2.7-22.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/phatch-0.2.7-22.fc22

Comment 13 Fedora Update System 2015-07-18 02:10:37 UTC
Package phatch-0.2.7-22.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing phatch-0.2.7-22.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-11800/phatch-0.2.7-22.fc22
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2015-07-30 13:55:39 UTC
phatch-0.2.7-22.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.