Bug 119292 - can't change the vt
can't change the vt
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-28 23:21 EST by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 19:34:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2004-03-28 23:21:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.4.1)
Gecko/20031114

Description of problem:
usually everyone uses Ctrl+Alt+Fn to change the vt from X. however it
doesn't work if the kernel without selinux=0 is booted. when it
happens, X server looks like freezing, because it shows the desktop
and no mouse icon say. but when I press Alt+F7, the mouse icon appears
again and I can operate something on X.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot the kernel enabled selinux
2.press Ctrl+Alt+F1
3.
    

Actual Results:  no changes to the vt.

Expected Results:  can changes to the vt.

Additional info:
Comment 1 Mike A. Harris 2004-03-29 12:56:07 EST
Reassigning to SElinux policy component.
Comment 2 Daniel Walsh 2004-03-29 13:17:50 EST
Could you send the avc messages from /var/log/messages?  Since you ran
with selinux=0 you need to relabel.  You should use enforcning=0 which
turns of the denials.

Dan
Comment 3 Akira TAGOH 2004-03-29 19:34:52 EST
I have tried enforcing=0 first, but it didn't help. and even if this
problem appears on my test box, no related messages are output to
/var/log/messages.
btw I haven't seen this issue on FC2-1.91-test2 yet. so I'm closing
this and will reopen if I see this again.

Thanks,

Note You need to log in before you can comment on or make changes to this bug.