Bug 1192929 - [rpcgssd service] service rpcgssd force-reload should not start the service if rpcgssd is not running
Summary: [rpcgssd service] service rpcgssd force-reload should not start the service i...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-16 09:14 UTC by Yongcheng Yang
Modified: 2016-08-29 08:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-24 20:02:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yongcheng Yang 2015-02-16 09:14:23 UTC
Description of problem:
"service rpcgssd force-reload" should not start the service if rpcgssd is not running.
As the LSB said "force-reload	cause the configuration to be reloaded if the service supports this, otherwise restart the service if it is running". But i find that the "force-reload" just acts the same as "restart" due to /etc/init.d/rpcgssd

Version-Release number of selected component (if applicable):
RHEL-6.6

How reproducible:
100%

Steps to Reproduce:
1.service rpcgssd stop
2.service rpcgssd force-reload
3.service rpcgssd status

Actual results:
[16:34:11 root@ ~~]# service_rpcgssd stop
Stopping RPC gssd: [  OK  ]
:: [   PASS   ] :: Service have to implement stop function (Expected 0, got 0)
--------------------------------------------------------------------------------
[16:34:11 root@ ~~]# service_rpcgssd condrestart
:: [   PASS   ] :: Service have to implement condrestart function (Expected 0, got 0)
--------------------------------------------------------------------------------
[16:34:11 root@ ~~]# service_rpcgssd try-restart
:: [   PASS   ] :: Service have to implement try-restart function (Expected 0, got 0)
--------------------------------------------------------------------------------
[16:34:12 root@ ~~]# service_rpcgssd force-reload
Stopping RPC gssd: [FAILED]
Starting RPC gssd: [  OK  ]
:: [   PASS   ] :: Service have to implement force-reload function (Expected 0, got 0)
--------------------------------------------------------------------------------
[16:34:12 root@ ~~]# service_rpcgssd status
rpc.gssd (pid 41006) is running...

Expected results:
The "force-reload" does nothing when the rpcgssd service is not running.

Additional info:
The same action on rhel7 not start the service if rpc-gssd is not running

Comment 2 Steve Dickson 2015-02-16 12:57:42 UTC

*** This bug has been marked as a duplicate of bug 1192926 ***

Comment 3 Steve Dickson 2016-08-24 20:02:03 UTC
restart | force-reload | reload all do the same thing


Note You need to log in before you can comment on or make changes to this bug.