Bug 119293 - (IDE CD)Kernel Panic In interrupt handler (mounting IDE CDROM)(
(IDE CD)Kernel Panic In interrupt handler (mounting IDE CDROM)(
Status: CLOSED DUPLICATE of bug 115458
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-03-28 23:35 EST by Luke
Modified: 2015-01-04 17:05 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-24 01:03:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Luke 2004-03-28 23:35:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
When booting from the Fedora Core 2 Test 1 Cd #1 just after "running
/sbin/loader" the system shows a kernel panic and halts.  I have seen
the same issue with Gentoo using their 2.6.x kernels and I believe it
is an issue with the kernel and mounting a standard IDE CD-ROM drive.
Tried noprobe and askmethod startup options with no success.  I have
no problems with this drive and kernels based on 2.4.x

Version-Release number of selected component (if applicable):
Fedora Core 2 Test 1 (kernel 2.6.x)

How reproducible:

Steps to Reproduce:
1.  Boot from CD.

Actual Results:  Kernel Panic

Expected Results:  load Anaconda Installer

Additional info:

The last three lines of the kernel dump.
Code: 0f 0b 2f 04 ab d6 33 c0 89 2b 8b 44 24 3c 89 83 fc 00 00 00
 <0>Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing

My hardware configuration (nothing special)
MB: Intel ICH4 chipset
CPU: P3 Celeron 1300
Nvidia GeForce DDR
Soundblaster Live
Netgear FA311 NIC
40G Western Digital Drive
Afreey 50x CD-ROM drive (not CDR/RW)
Comment 1 Dave Jones 2004-03-29 07:35:46 EST
Is there a backtrace available too? And possibly a ..

"Kernel BUG at ..." message?
Comment 2 Luke 2004-03-29 14:25:20 EST
I'll be glad to give you any information that will be helpful.  The
only problem is you will have to tell me exactly how to get it.  This
occurs while booting from the cd and the hard drive has no file system
on it. Which could be done depending on want you suggest but unless
you know of a trick to capture the data to a file I'm not sure how to
get all of it.  Writing it all down is ok exempt for half the
information scrolls off of the screen and the system doesn't respond
after that.  I plan on swapping out the CDrom drive for another and
see if that is the issue, if it is I don't understand why it works
with no issues and no special configurations in 2.4.x based kernels
and not 2.6.x.  Also on my things to do is to get more detailed
information about the MB chipset and try test 2 that just came out.
Comment 3 Luke 2004-03-30 09:39:15 EST
Replacing the CDROM drive corrected the problem.
Comment 4 Marc Deslauriers 2004-04-26 18:25:31 EDT
I had the exact same problem here trying to install Fedora Core 2 Test
3. This is on a test machine that runs Fedora Core 1 and a whole lot else.

I opened it up, and sure enough it had an Afreey 50X cd-rom also.

It seems kernel 2.6 doesn't like that model.

Replacing the cd-rom drive worked for me too.
Comment 5 Dave Jones 2004-06-14 20:10:12 EDT
interesting, could be some hardware quirk with that drive.

if it still does it with a current kernel, you may want to bring this
to the attention of Jens Axboe <axboe@suse.de> who is the cdrom
Comment 6 Glen Starrett 2004-06-18 16:11:23 EDT
I just repeated this (several times, with 2 different CD's) with FC2.
 Is there any more information I can provide on this?

I'll send a note to Jens as indicated above.
Comment 7 Dave Jones 2004-12-07 01:09:38 EST
still a problem with the current errata kernel ?
Comment 8 Marc Deslauriers 2004-12-07 13:30:57 EST
Sorry, I can't retest this. The CD-ROM has been removed from the system.

I may still have it somewhere if anyone wants it to test with.
Comment 9 Glen Starrett 2004-12-07 13:43:30 EST
I still have that CDROM in my system here (running a different distro).  I don't
know how to burn a bootable CD with errata kernel though.  If you can point me
to some simple instruction or an ISO I'll test it out.
Comment 10 Dave Jones 2005-02-13 00:12:00 EST
you could grab the boot.iso from the development dir of
download.fedora.redhat.com (this is the rawhide kernel that will go on to become
FC4). You don't need to do a full install, just make sure it gets as far as the
Comment 11 John DeDourek 2005-02-15 08:14:13 EST
There's ;more info on this bug in Bug Number 115458 It has been outstanding a
long time.  You could try adding ide=nodma to the boot line when installing.
Comment 12 Dave Jones 2005-02-24 01:03:34 EST

*** This bug has been marked as a duplicate of 115458 ***
Comment 13 juan fernandez 2005-11-03 10:06:39 EST
I have the same problem on a labtop dell inspirion 5160 and a RHEL WS4.
But what is wheird is that I have already a RHEL4 install on it and I want to
reinstall it, but the think is that I can't get it to work, just after the
loader the kernel doesn't get uncompressed correctly and I have the kernel panic
error message.
I can't obviously change the cd drive

thanks juan

Note You need to log in before you can comment on or make changes to this bug.