Bug 1192930 - Julia fails to build in rawhide since gcc 5.0.0-0.12.fc23
Summary: Julia fails to build in rawhide since gcc 5.0.0-0.12.fc23
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-16 09:16 UTC by Milan Bouchet-Valat
Modified: 2015-02-16 13:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 13:53:58 UTC
Type: Bug


Attachments (Terms of Use)

Description Milan Bouchet-Valat 2015-02-16 09:16:57 UTC
Package Julia fails to build in rawhide since gcc 5.0.0-0.12.fc23 has been uploaded to the repos. I'm building nightlies in Copr at https://copr.fedoraproject.org/coprs/nalimilan/julia-nightlies/, and suddenly the build started to fail only on rawhide. So I've tested rebuilding the existing version, and it fails too. I'm not sure the problem is gcc, but it looks like a good candidate.

Note Julia was not listed in the failing packages in your message to fedora-devel: https://lists.fedoraproject.org/pipermail/devel/2015-February/207549.html

The error is:
g++ -march=x86-64 -m64 -O3 -ggdb3 -falign-functions -momit-leaf-frame-pointer -I/builddir/build/BUILD/julia-0.3.5/src -I/builddir/build/BUILD/julia-0.3.5/src/support -I/builddir/build/BUILD/julia-0.3.5/build/usr/include -Wall -Wno-strict-aliasing -fno-omit-frame-pointer repl.o -o /builddir/build/BUILD/julia-0.3.5/build/usr/bin/julia -L/builddir/build/BUILD/julia-0.3.5/build/usr/lib64/julia -L/builddir/build/BUILD/julia-0.3.5/build/usr/lib64 -L/builddir/build/BUILD/julia-0.3.5/build/usr/lib64 -ljulia -Wl,-Bdynamic -Wl,--no-whole-archive -ldl -lrt -lpthread -Wl,--export-dynamic -Wl,--version-script=/builddir/build/BUILD/julia-0.3.5/src/julia.expmap -Wl,--no-whole-archive -lunwind-generic -lunwind -L/usr/lib64/llvm -lLLVM-3.5.0 -Wl,-rpath,$ORIGIN/../lib64/julia -Wl,-rpath,$ORIGIN/../lib64 -Wl,-z,origin
/builddir/build/BUILD/julia-0.3.5/build/usr/lib64/libjulia.so: undefined reference to `llvm::TargetRegistry::lookupTarget(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&)'
/builddir/build/BUILD/julia-0.3.5/build/usr/lib64/libjulia.so: undefined reference to `llvm::LoopPass::createPrinterPass(llvm::raw_ostream&, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) const'
/builddir/build/BUILD/julia-0.3.5/build/usr/lib64/libjulia.so: undefined reference to `llvm::EngineBuilder::selectTarget(llvm::Triple const&, llvm::StringRef, llvm::StringRef, llvm::SmallVectorImpl<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > const&)'
/builddir/build/BUILD/julia-0.3.5/build/usr/lib64/libjulia.so: undefined reference to `llvm::raw_fd_ostream::raw_fd_ostream(char const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >&, llvm::sys::fs::OpenFlags)'
collect2: error: ld returned 1 exit status

See this Koji build for details:
http://koji.fedoraproject.org/koji/taskinfo?taskID=8948758

Comment 1 Milan Bouchet-Valat 2015-02-16 13:30:40 UTC
Looks like this may be because LLVM hasn't been rebuilt yet on rawhide, as the buidl succeeds on F22. I'm going to try with a rebuilt LLVM.

Comment 2 Milan Bouchet-Valat 2015-02-16 13:53:58 UTC
Rebuilding LLVM fails on rawhide currently. I'll leave that to the maintainer and retry later.


Note You need to log in before you can comment on or make changes to this bug.