Bug 119295 - Xmodmap and Xkbmap simultaneously, still don't work?
Xmodmap and Xkbmap simultaneously, still don't work?
Status: CLOSED DUPLICATE of bug 117221
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-03-29 01:28 EST by Behdad Esfahbod
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:02:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2004-03-29 01:28:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.1.12

Description of problem:
The code in /etc/X11/xinit/xinitrc says that "xkb and xmodmap don't
play nice together", and disables xmodmap if xkb is in the game.  The
same code is in /etc/X11/xdm/Xsession.

I'm wondering if it's still the case or not.  I use xkb to set my
keyboard layout to us+ir, and use xmodmap to switch the LTGT key to
act like Left-Shift, and by commenting the suspicious part in the two
above files, it works fine.

I'm sure that there has been a reason to do this, but thought the
problem may have been solved by now.  Or otherwise, perhaps a way to
explicitly say I want both is good, perhaps by checking for existance
of a file like /etc/X11/Xkbandmodmap!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Check the source!

Additional info:
Comment 1 Behdad Esfahbod 2004-03-29 02:00:53 EST
Well, commenting the lines used to work, but doesn't anymore.  So even
when I comment the lines, first xinitrc sets xkb, then xmodmap, then
gnome-session resets xkb and so the Xmodmap config goes to /dev/null.
 Another xmodmap after gnome-session initializes Xkb does the job.
Comment 2 Mike A. Harris 2004-03-30 17:24:16 EST
Sounds like this is a GNOME bug stomping on the configuration
done by X startup scripts.

Comment 3 Mike A. Harris 2004-03-30 17:31:02 EST
Can you review bug #119217 and bug #119018 to see if you can reproduce
either of those issues, and wether they may be related to the problem
you're experiencing?  I believe all 3 of these bugs may be duplicates
of each other.
Comment 4 Behdad Esfahbod 2004-03-30 22:32:31 EST
Hi Mike,

The two other bugs are irrelevant in my opinions (see my comments on
them).  I think that it's just that GNOME is stomping as you suggested.
Comment 5 Nils O. Selåsdal 2004-05-19 17:09:38 EDT
Is this be releated to the Xmodmap (/etc/X11/Xmodmap) not beeing
loaded in FC 2 ? I copied over my Xmodmap from FC1, but FC2 doesn't
seem to load it. Any suggestion where I can stuff the loading of
/etc/X11/Xmodmap  ?
Comment 6 Behdad Esfahbod 2004-05-19 17:18:22 EDT
Yes.  That GNOME resets the keyboard settings and just loads xkb. 
(also there's an outdated if in some scripts that if xkb is used, does
not load xmodmap, but that's another story)
Comment 7 Enrico Scholz 2004-05-19 18:46:38 EDT
see bug #117221
Comment 8 Mike A. Harris 2004-09-21 05:30:03 EDT

*** This bug has been marked as a duplicate of 117221 ***
Comment 9 Red Hat Bugzilla 2006-02-21 14:02:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.