Bug 119297 - Bad: sendmail -bv root segfaults when sendmail uses aliases from LDAP
Bad: sendmail -bv root segfaults when sendmail uses aliases from LDAP
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-29 02:21 EST by O W
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 07:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description O W 2004-03-29 02:21:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.0.3705)

Description of problem:
Sendmail cannot use alias from LDAP, when the sendmail.cf file
uses ldap -k in AliasFile. The identical sendmail.cf under redhat9
with sendmail-8.12.8 performs ldap alias lookups without problems.

Digging into the problem, it appears that if sendmail is built
again libsasl and not libsasl2, the problem goes away.
Also -DSASL was specified instead of -DSASL=2

There seems to be some bug in libsasl2 that prevents ldap lookups.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Edit you sendmail.cf AliasFile to read aliases from LDAP.ie. 
AliasFile=/etc/aliases,ldap: -k "(&(objectclass=mailRecipient)(cn=%
0))" -v mail
2. Restart sendmail.
3. Run sendmail -bv <ldapuser>. Segmentation fault occurs. sendmail -
bv user@realhost.com does not cause segfault.
4. This requires an ldap server of coruse.
    

Actual Results:  Segmentation Fault.

Expected Results:  user@realhost.com....deliverable: mail relay, host 
mailhub.realhost.com, user User.Name@realhost.com


Additional info:

The problem is there in sendmail-8.12.10-1 (WS3)
but not in sendmail-8.12.8-4 (redhat9)
The difference seems to be that the WS3 version uses sasl2, and
When recompiled against sasl instead of sasl2 the problem goes away.

Note You need to log in before you can comment on or make changes to this bug.