Bug 11930 - Adduser corrupts /etc/group file
Adduser corrupts /etc/group file
Status: CLOSED DUPLICATE of bug 3809
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-06 16:22 EDT by silver.wolf
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-06 16:24:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cutting of the /etc/group file, for the groups involved in the problem (16.01 KB, text/plain)
2000-06-06 16:24 EDT, silver.wolf
no flags Details

  None (edit)
Description silver.wolf 2000-06-06 16:22:02 EDT
I am having a lot of trouble using adduser on a RedHat 6.0 box. I also 
upgraded to the newest shadow-utils, but nothing changed:

I often use a shell script to add several users at once, but after some 
time, as the number of users grew, every time I add a new user, either by 
script or interactively, the /etc/group file gets corrupted: if the new 
user is also member of a group that already contains many users (in fact 
the number of users doesn't matter, the problem arises when the char count 
for the users in the group+the group name+the commas is greater than a 
fixed amount -8192-), then the user list for that group is broken, with 
several blank lines inserted, making user creation almost impossible.

I could not imagine what it is caused by, just was wondering if similar 
problems have already been reported.

Bye
Comment 1 silver.wolf 2000-06-06 16:24:10 EDT
Created attachment 318 [details]
cutting of the /etc/group file, for the groups involved in the problem
Comment 2 Bernhard Rosenkraenzer 2000-07-18 14:09:07 EDT

*** This bug has been marked as a duplicate of 3809 ***

Note You need to log in before you can comment on or make changes to this bug.