Bug 1193116 - Packages have file name conflict between bind-sdb and pdns, /usr/share/man/man1/zone2ldap.1.gz
Summary: Packages have file name conflict between bind-sdb and pdns, /usr/share/man/ma...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pdns
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Morten Stevens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-16 15:29 UTC by stan
Modified: 2015-03-25 20:05 UTC (History)
6 users (show)

Fixed In Version: pdns-3.4.3-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-27 09:22:58 UTC


Attachments (Terms of Use)

Description stan 2015-02-16 15:29:21 UTC
Description of problem:
There is a file name conflict between pdns and bind-sdb.
Transaction check error:
file /usr/share/man/man1/zone2ldap.1.gz from install of bind-sdb-32:9.9.6-7.P1.fc21.x86_64 conflicts with file from package pdns-3.4.2-1.fc21.x86_64

Version-Release number of selected component (if applicable):
See above error message.

How reproducible:
Every time.

Steps to Reproduce:
1.  Install pdns or bind-sdb
2.  Try to install the other package
3.

Actual results:
Above error

Expected results:
Co-exist peacefully.

Additional info:

Comment 1 Tomáš Hozza 2015-02-17 08:01:08 UTC
The man page was in bind-sdb for ages and is a different tool than what is distributed in pdns.

The issue is caused by the latest change in pdns
http://pkgs.fedoraproject.org/cgit/pdns.git/diff/pdns.spec?h=f21&id=5150faa5785cb79265ef02eb17fdb3f5b739b5b4

Comment 2 stan 2015-02-17 15:21:21 UTC
Thank you for your response, and research.  Should I close this ticket as notabug and re-open it against pdns?  Or can it be re-assigned somehow?

Comment 3 Tomáš Hozza 2015-02-17 15:50:05 UTC
(In reply to stan from comment #2)
> Thank you for your response, and research.  Should I close this ticket as
> notabug and re-open it against pdns?  Or can it be re-assigned somehow?

It's already reassigned. There is no need for any action from your side.

Comment 4 Fedora Update System 2015-02-17 16:52:18 UTC
pdns-3.4.2-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pdns-3.4.2-2.fc21

Comment 5 Fedora Update System 2015-02-17 16:52:50 UTC
pdns-3.4.2-2.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/pdns-3.4.2-2.el7

Comment 6 Fedora Update System 2015-02-19 02:59:06 UTC
Package pdns-3.4.2-2.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pdns-3.4.2-2.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2271/pdns-3.4.2-2.fc21
then log in and leave karma (feedback).

Comment 7 stan 2015-02-19 03:27:04 UTC
Yes, this solves the problem.  Thank you.

Comment 8 Fedora Update System 2015-02-27 09:22:58 UTC
pdns-3.4.2-2.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2015-03-02 16:51:34 UTC
pdns-3.4.3-1.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/pdns-3.4.3-1.el7

Comment 10 Fedora Update System 2015-03-25 20:05:50 UTC
pdns-3.4.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.