Bug 1193123 - unexpected error when changing period range in the dashboards
Summary: unexpected error when changing period range in the dashboards
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-3.6.2
: 3.6.0
Assignee: Shirly Radco
QA Contact: Petr Kubica
URL:
Whiteboard:
Depends On:
Blocks: 1119603 1286419
TreeView+ depends on / blocked
 
Reported: 2015-02-16 15:40 UTC by Petr Kubica
Modified: 2016-03-09 21:16 UTC (History)
11 users (show)

Fixed In Version: rhevm-reports-3.6.2-1.el6ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 21:16:41 UTC
oVirt Team: Reports


Attachments (Terms of Use)
reports-log (26.18 KB, application/x-gzip)
2015-02-16 15:40 UTC, Petr Kubica
no flags Details
screenshot (61.67 KB, image/png)
2015-02-16 15:42 UTC, Petr Kubica
no flags Details
pg_dump of ovirt_engine_history db (1.84 MB, application/octet-stream)
2015-02-26 10:39 UTC, Petr Kubica
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0425 normal SHIPPED_LIVE rhevm-reports bug fix and enhancement update 2016-03-10 01:21:14 UTC

Description Petr Kubica 2015-02-16 15:40:48 UTC
Created attachment 992254 [details]
reports-log

Description of problem:
While choosing period range to different than daily in Host OS Break Down (BR22B) for system overview.

it give me an:

Unexpected error

com.jaspersoft.jasperserver.api.JSExceptionWrapper: Error executing SQL statement for : startDate

Version-Release number of selected component (if applicable):
rhevm-reports-3.5.0-10.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open "Host OS Break Down (BR22B) for system overview" page
2. Choose period range to yearly

Actual results:
Enexpected error.

Additional info:
attached logs from repors

Comment 1 Petr Kubica 2015-02-16 15:42:42 UTC
Created attachment 992255 [details]
screenshot

Comment 2 Petr Kubica 2015-02-18 09:16:52 UTC
the same error is on "Inventory Dashboard", "System Overview Dashboard" and "Uptime Dashboard" page too

Comment 3 Shirly Radco 2015-02-25 09:27:20 UTC
(In reply to Petr Kubica from comment #0)
> Created attachment 992254 [details]
> reports-log
> 
> Description of problem:
> While choosing period range to different than daily in Host OS Break Down
> (BR22B) for system overview.
> 
> it give me an:
> 
> Unexpected error
> 
> com.jaspersoft.jasperserver.api.JSExceptionWrapper: Error executing SQL
> statement for : startDate
> 
> Version-Release number of selected component (if applicable):
> rhevm-reports-3.5.0-10.el6ev.noarch
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Open "Host OS Break Down (BR22B) for system overview" page
> 2. Choose period range to yearly
> 
> Actual results:
> Enexpected error.
> 
> Additional info:
> attached logs from repors

Hi Petr,

Please attach a db dump for history db:
/usr/bin/pg_dump -U "<user>" -F custom -f "<file>" "<db name>"

Comment 4 Petr Kubica 2015-02-26 10:39:45 UTC
Created attachment 995517 [details]
pg_dump of ovirt_engine_history db

Comment 5 Petr Kubica 2015-02-26 10:43:37 UTC
Hi Shirly,

Dump attached.
Created using the provided command.

Comment 6 Shirly Radco 2015-06-25 10:17:53 UTC
I now tried to reproduce this error but with no success.
Can you please check if this still persists?

Comment 7 Petr Kubica 2015-06-29 14:31:34 UTC
I can still reproduce this error in rhevm-reports-3.5.3-1.el6ev.noarch
jasper-libs-1.900.1-16.el6_6.3.x86_64
jasperreports-server-pro-5.5.0-10.el6ev.noarch

Installed as clean environment without any data

Comment 8 Petr Kubica 2015-06-29 14:35:35 UTC
my steps:
1. install engine & dwh & reports
2. open Host OS Break Down (BR22B) for system overview
3. click on Options
4. Change Daily to Monthly

during the change, it shows the same error

Comment 9 Yaniv Lavi 2015-08-13 09:33:17 UTC
(In reply to Petr Kubica from comment #8)
> my steps:
> 1. install engine & dwh & reports
> 2. open Host OS Break Down (BR22B) for system overview
> 3. click on Options
> 4. Change Daily to Monthly
> 
> during the change, it shows the same error

Are you using reports portal dashboards or directly accessing report?
Because this is in 'System Reasources' which should not be accessed directly and user role can not see only execute.

Comment 10 Petr Kubica 2015-08-22 13:49:56 UTC
I'm using reports portal and I opened Host OS Break Down (BR22B) for system overview in Library. I login as "admin" to reports portal. The issue is still in rhevm-reports-3.5.3-1.el6ev.noarch.

Comment 11 Yaniv Lavi 2015-08-23 09:16:15 UTC
(In reply to Petr Kubica from comment #10)
> I'm using reports portal and I opened Host OS Break Down (BR22B) for system
> overview in Library. I login as "admin" to reports portal. The issue is
> still in rhevm-reports-3.5.3-1.el6ev.noarch.

You should not test reports that are located in 'System Resources'.
You can login with user role and you won't even see them.
This report should be tested via the reports portal dashboards that are in the 'Dashboards' folder, do you see a error using system overview dashboard?

Comment 12 Petr Kubica 2015-08-25 12:09:30 UTC
If you show the dashboards in reports portal (home -> dashboard - View list) and you open the "Inventory Domain" or "System Overview Dashboard" and change the "Period range", you will see the same exception. (I wrote about this in comment #2)

If the user (admin) see the items in Library and opened them (he can access to these items), it should work. Any exception shouldn't be displayed and it should display the relevant data. 
The second way is hide 'non-working' items in Library if the admin should not working with them. So he will not be confused when he will see the exception.

Comment 13 Petr Kubica 2015-08-25 12:46:02 UTC
After the startDate exceptions, if you try to change Date, you will see another exception:

Unexpected error
com.jaspersoft.jasperserver.api.JSExceptionWrapper: Error executing SQL statement for : Data_Centers

Comment 14 Eyal Edri 2015-12-17 13:58:24 UTC
RHEV 3.6.0 BETA2 is out, any open bugs are moved to the BETA3 milestone.

Comment 15 Petr Kubica 2016-01-07 16:02:09 UTC
Verified in rhevm-reports-3.6.2.1-1.el6ev.noarch

Comment 17 errata-xmlrpc 2016-03-09 21:16:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0425.html


Note You need to log in before you can comment on or make changes to this bug.